[Ifeffit] Artemis fit error - chi-square and R-factors are always equal to 0

Matt Newville newville at cars.uchicago.edu
Fri Mar 26 12:13:59 CDT 2021

Hi Ava,

Sorry for the trouble.   It looks to me like the fit actually ran.  Like,
getting non-trivial and non-starting values and uncertainties for 'ss_Cu1',
'dr_Cu1', etc tells me that many parts of the fit and code worked.   I'm
not at all sure why Chi-square and R-factor would report 0.

Do you get a plot of the fit, and if so, does it look reasonable?
Can you send any additional information about how the fit is being defined
- like data file (or is this one of the example Cu data sets?) and feff.dat
file used?

On Fri, Mar 26, 2021 at 6:32 AM Ava Rajh <ava.rajh at ijs.si> wrote:

> Hello,
> I have recently installed Demeter suite on my LinuxMint 20 machine with
> all required dependencies met. Athena works well and Demeter passed all
> tests during installation. When running Artemis however, there is an
> issue with fits that persists with provided examples any any other
> projects I open (including the ones done by colleagues and just re-run
> on my machine).
> After the fit (which completes fine and returns expected fit that looks
> ok when comparing it to experiment), when inspecting the log file,
> chi-square, reduced chi-square and R values are equal to 0 (example log
> file attached bellow). No errors accompany the fit.
> I am using Larch installed with anaconda, and Artemis uses Feff6
> executable. I have re-installed Demeter and tried to get it to work with
> Ifeffit but the error persists. I have found an existing git hub thread
> dealing with similar issue
> (https://github.com/bruceravel/demeter/issues/62) but no solution that I
> could discern. Could it be an issue with my perl version (5.30.0)?

Maybe.  That issue seemed to start with a problem of not being able to find
and run Feff.
I don't know if that is relevant for you - it sure seems like Feff6 ran for
you - can you verify that?

I'm also not sure if that issue ever got resolved.  I was sure confused
about what was going on there.

For sure, it is much easier for me to support and help folks using Larch.
Can you verify that the example fitting scripts for Larch (see
https://github.com/xraypy/xraylarch/tree/master/examples/feffit ) work for

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20210326/1f1c6b43/attachment.htm>

More information about the Ifeffit mailing list