[Ifeffit] Artemis hung up on importing fpj containing VPaths

Nicholas Marcella nicholas.marcella at stonybrook.edu
Mon Dec 10 14:57:15 CST 2018

Hi All,

I'm trying to import an Artemis project that contains VPaths. The import
stalls on the "importing VPaths" step. There is no error. The program
crashes when I click on the GUI. I tried to recreate this issue and found
that the following steps do so:

Note: Step 5 is critical. If a fit is not run within the project file, the
VPaths are loaded successfully.

To recreate:
1) Import FEFF calculation and some data set.
2) Add some number of paths to the data set
3) Mark all paths and Alt+shift+m
4) transfer VPath to plotting list. Plot.
5) Run a basic fit.
6) save and close. Exit Artemis.
7) Open Artemis, try to import the project.

p.s. I tried deleting %APPDATA% and doing a reinstall.

As for a quick solution: is there anyway I can skip importing VPaths when
loading my project file?

*Nicholas J. Marcella* | PhD Student
*Materials Science and Chemical Engineering*
*Stony Brook University*
*Tel: (914)-703-9843*

*Structure and Dynamics of Applied Nanomaterials | Brookhaven National Lab
*Senator - MSCE | Graduate Student Organization
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20181210/a93c422a/attachment.html>

More information about the Ifeffit mailing list