[Ifeffit] Problem with Demeter 0.9.18 pluck tool

Ravel, Bruce bravel at bnl.gov
Fri Sep 27 14:40:02 CDT 2013


I have a question.  What gnuplot terminal do you use?  That is, what's the value of the gnuplot->terminal configuration parameter?

It seems that the way I do the pluck buttons does not work with the X11 terminal, but it should work with the wxt terminal.  So if that parameter is set to "X11", change it to "wxt", then try plucking again.


 Bruce Ravel  ------------------------------------ bravel at bnl.gov

 National Institute of Standards and Technology
 Synchrotron Methods Group at NSLS --- Beamlines U7A, X24A, X23A2
 Building 535A
 Upton NY, 11973

 Homepage:    http://xafs.org/BruceRavel
 Software:    https://github.com/bruceravel

From: ifeffit-bounces at millenia.cars.aps.anl.gov [ifeffit-bounces at millenia.cars.aps.anl.gov] on behalf of Denis Testemale [denis.testemale at grenoble.cnrs.fr]
Sent: Friday, September 27, 2013 8:24 AM
To: ifeffit mailing list
Subject: [Ifeffit] Problem with Demeter 0.9.18 pluck tool

Dear members of the list,
I finally got the opportunity to start using Dathena. I don't know if
I've found a bug or if I'm doing something stupid (chances are not too
low, actually...).

- I am using Ubuntu 13.04
- Demeter 0.9.18 (I did the upgrade to 0.9.18 but ran into some error
messages as reported on September 10th on this list, could they be
related to the behaviour I am reporting here?).
- I cannot say if it worked before the upgrade to 0.9.18 since I never
took the time to use Demeter properly until now.

I'm trying to pick/pluck a value from the graph.
- When I first launch Dathena, and I press a pluck button for the first
time I can see the expected message at the bottom of the GUI ("Double
click on a point to pluck its value ..."): as hard as I tried (I tried
many different combinations) I could never get the thing to work
(parameter value in the 'box' never records the value where I double
click). After 10s I see the 'Pluck timed out' message.
- Then, when I click again on the pluck button, a value is recorded
instantly in the 'box' without any double-clicking from me, and this
value is crazy. An example: for a low k parameter of the FT I get
-100000. The example in the attached screenshot shows a value for the
normalization range low limit at -107112.52eV (note that the E0 value is
'integrated' in this number: the iron edge at 7112.52, see screenshot. I
tried another set of data, silver K edge and the same thing occured: a
weird number, with the E0 value inside, got recorded in the 'box).
- Same problem with Dartemis.

Tell me what I can do to help... or what I'm doing stupid.

More information about the Ifeffit mailing list