[Ifeffit] Athena can not open any file

Bruce Ravel bravel at bnl.gov
Tue Aug 12 15:54:05 CDT 2008


Reading your story, I see that I have made a mistake building tarballs
from the files managed by my svn repository.  As you have discovered,
by following my instructions, Ifeffit.pm (a rather important piece of
code -- it is the wrapper that allows perl to talk to ifeffit) never
gets installed.

Yikes!  Getting all this packaging stuff right so that it works on all
the platforms is really hard!  I apologize for the confusion.

I have put the missing piece on my web site.  I'll move this tarball
to the correct location when I have a bit of free time.  Here is the URL:


Grab and build this.  Note that some code gets compiled.  Hopefully,
the magic will happen so it gets compiled correctly on your 64bit

Let me know how it works out.


P.S.  I am very grateful that you are sticking with this and letting
me know about the troubles you are running into.  The code would
really suck a lot more without people like you willing to help us make
things work properly.

On Tuesday 12 August 2008 15:36:42 Gilberto Fernandes Lopes Fabbris wrote:
> Hello again,
> I tried to install the new package of both ifeffit(1.2.11) and horae (0.67)
> but it also didn't work.
> I first removed any file related to ifeffit and horae that I could find.
> Pgplot, ifeffit, Xray-Absorption, Xray-Scattering and Chemistry-Formula
> installation runned without error and I could open ifeffit on command line.
> But the error mensage below appeared when I runned the "perl Build.PL" on
> horae.
> ...
> Checking whether your kit is complete...
> Looks good
> Checking prerequisites...
> Package 'Config::IniFiles' already declared with version '2.39',
> ignoring subsequent declaration.
> Looks good
> Deleting Build
> Removed previous script 'Build'
> Creating new 'Build' script for 'horae' version '067'
> ...
> Even though this error I runned ./Build and ./Build install and no error
> appeared. But when I tried to run athena (it also happens on artemis) the
> error appeared:
> ......
> Can't locate Ifeffit.pm in @INC (@INC contains:
> /usr/lib/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0
> /usr/lib/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
> /usr/lib/perl5/site_perl/5.10.0
> /usr/lib/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi
> /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at
> /usr/bin/athena line 67.
> BEGIN failed--compilation aborted at /usr/bin/athena line 67.
> .....
> I looked for the Ifeffit.pm file on /usr/lib/perl5 and it doesnt exist.
> Thanks,
> Gilberto
> ps: I will write on the FAQ as soon as possible... :)
> _______________________________________________
> Ifeffit mailing list
> Ifeffit at millenia.cars.aps.anl.gov
> http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit

 Bruce Ravel  ------------------------------------ bravel at bnl.gov

 National Institute of Standards and Technology
 Synchrotron Methods Group at NSLS --- Beamlines U7A, X24A, X23A2
 Building 535A
 Upton NY, 11973

 My homepage:    http://xafs.org/BruceRavel
 EXAFS software: http://cars9.uchicago.edu/~ravel/software/exafs/

More information about the Ifeffit mailing list