[Ifeffit] Athena can not open any file

Gilberto Fernandes Lopes Fabbris gfabbris at lnls.br
Tue Aug 12 14:36:42 CDT 2008

Hello again,

I tried to install the new package of both ifeffit(1.2.11) and horae (0.67)
but it also didn't work.

I first removed any file related to ifeffit and horae that I could find.
Pgplot, ifeffit, Xray-Absorption, Xray-Scattering and Chemistry-Formula
installation runned without error and I could open ifeffit on command line.
But the error mensage below appeared when I runned the "perl Build.PL" on

Checking whether your kit is complete...
Looks good

Checking prerequisites...
Package 'Config::IniFiles' already declared with version '2.39',
ignoring subsequent declaration.
Looks good

Deleting Build
Removed previous script 'Build'

Creating new 'Build' script for 'horae' version '067'

Even though this error I runned ./Build and ./Build install and no error
appeared. But when I tried to run athena (it also happens on artemis) the
error appeared:

Can't locate Ifeffit.pm in @INC (@INC contains:
/usr/lib/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0
/usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at
/usr/bin/athena line 67.
BEGIN failed--compilation aborted at /usr/bin/athena line 67.

I looked for the Ifeffit.pm file on /usr/lib/perl5 and it doesnt exist.



ps: I will write on the FAQ as soon as possible... :)

More information about the Ifeffit mailing list