<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">Hi again,<div class=""><br class=""></div><div class="">I have rebuilt things more carefully but I still have problems.</div><div class=""><br class=""></div><div class="">- I built pgplot following the instructions at <a href="http://www.iac.es/sieinvens/siepedia/pmwiki.php?n=HOWTOs.PGPLOTMacOSX" class="">http://www.iac.es/sieinvens/siepedia/pmwiki.php?n=HOWTOs.PGPLOTMacOSX</a>. It works fine and the test produces png files. </div><div class=""><br class=""></div><div class="">- I have been building ifeffit in various ways. The current version of my ./configure command looks like this:</div><div class="">$ ./configure --with-fortran=gfortran --with-pgplot=/usr/local/lib/pgplot --with-pgplot-link='-L/usr/local/lib/pgplot -lpgplot -lXaPgplot -lcpgplot' CC=gcc-fsf-4.9 CFLAGS=-m64 FFLAGS='-ffixed-line-length-132 -m64' LDFLAGS='-L/usr/X11/lib -lX11 -lXt -lXaw3d -I/usr/local/include -I/sw10.9/include -L/sw10.9/lib -lpng’</div><div class=""><br class=""></div><div class="">gfortran and gcc are installed via fink. I have also tried Apples stock gcc. I have tried with and without the -m64 flags, with just pgplot or by also including XaPgplot and cpgplot.</div><div class=""><br class=""></div><div class="">The build seems to include pgplot, part of the output during the make is:</div><div class=""><div class="">make[3]: Entering directory '/Users/Anders/ifeffit/ifeffit/src/cmdline'</div><div class="">gcc-fsf-4.9 -DHAVE_CONFIG_H -I. -I. -I../..     -m64 -c iff_shell.c</div><div class="">gcc-fsf-4.9  -m64 -L/usr/X11/lib -lX11 -lXt -lXaw3d -I/usr/local/include -I/sw10.9/include -L/sw10.9/lib -lpng -o ifeffit  iff_shell.o ../lib/libifeffit.a  -L/usr/local/lib/pgplot -lpgplot -lXaPgplot -lcpgplot ../../readline/libreadline.a -L/usr/lib -lncurses -L/usr/X11/lib -L/sw10.9/lib -L/opt/intel/composer_xe_2015.0.077/compiler/lib -L/opt/intel/composer_xe_2015.0.077/mkl/lib -L/sw10.9/lib/gcc4.9/lib/gcc/x86_64-apple-darwin13.4.0/4.9.2 -L/sw10.9/lib/gcc4.9/lib/gcc/x86_64-apple-darwin13.4.0/4.9.2/../../.. -lX11 -lXt -lXaw3d -lpng -lgfortran -lSystem -lgcc_ext.10.5 -lquadmath -lm</div><div class="">make[3]: Leaving directory '/Users/Anders/ifeffit/ifeffit/src/cmdline’</div></div><div class=""><br class=""></div><div class="">The test of ifeffit still produces:</div><div class=""><div class="">$ ifeffit</div><div class=""> Ifeffit   1.2.12 Copyright (c) 2005 Matt Newville, Univ of Chicago</div><div class="">                command-line shell version 1.1 with GNU Readline</div><div class="">Ifeffit> testplot</div><div class=""> %PGPLOT, Unrecognized device type</div><div class=""> %PGPLOT, Invalid device specification: /AQT</div><div class=""> %PGPLOT, PGBBUF: selected graphics device is not open</div><div class=""> %PGPLOT, PGQCI: selected graphics device is not open</div><div class=""> %PGPLOT, PGQFS: selected graphics device is not open</div><div class=""> %PGPLOT, PGSCI: selected graphics device is not open</div><div class=""> %PGPLOT, PGSFS: selected graphics device is not open</div><div class=""> %PGPLOT, PGSVP: selected graphics device is not open</div><div class=""> %PGPLOT, PGBBUF: selected graphics device is not open</div><div class=""> %PGPLOT, PGEBUF: selected graphics device is not open</div><div class=""> %PGPLOT, PGSVP: selected graphics device is not open</div><div class=""> %PGPLOT, PGSCI: selected graphics device is not open</div><div class=""> %PGPLOT, PGSFS: selected graphics device is not open</div><div class=""> %PGPLOT, PGEBUF: selected graphics device is not open</div><div class="">  ** plot error: cannot open device:</div><div class=""> %PGPLOT, Unrecognized device type</div><div class=""> %PGPLOT, Invalid device specification: /AQT</div><div class="">  ** plot error: cannot open device:</div></div><div class=""><br class=""></div><div class="">I have run out of ideas of what to try next. </div><div class=""><br class=""></div><div class="">(The configure script picks up the paths for ifort libraries, could this be the problem? I could try to edit these out of all the makefiles… I don’t know how to make configure not pick these up.)</div><div class=""><br class=""></div><div class="">Any ideas much appreciated.</div><div class=""><br class=""></div><div class="">Anders</div><div class=""> <br class="">
<br class=""><div><blockquote type="cite" class=""><div class="">On Mar 19, 2015, at 14:55 PM, Bruce Ravel <<a href="mailto:bravel@bnl.gov" class="">bravel@bnl.gov</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><br class="">Anders,<br class=""><br class="">I see two things that look like problems.  I have never built Demeter<br class="">on a Mac myself, so there may be limits to how good my advice can be.<br class="">That said:<br class=""><br class="">You are clearly not linking against the pgplot library you compiled.<br class="">I glean this from the fact that you see this:<br class=""><br class="">   Use of uninitialized value $pgplot_location in substitution (s///)<br class="">   at DemeterBuilder.pm line 191.<br class=""><br class="">and this (from your previous email):<br class=""><br class="">   $ ifeffit<br class="">   Ifeffit   1.2.12 Copyright (c) 2005 Matt Newville, Univ of Chicago<br class="">                  command-line shell version 1.1 with GNU Readline<br class="">   Ifeffit> testplot<br class="">      %PGPLOT, Unrecognized device type<br class=""><br class="">and so on.  You need to make sure that pgplot is someplace that the<br class="">linker/loader knows to look when you build ifeffit.  But I do not know<br class="">how that works on the mac.<br class=""><br class="">The bigger problem is this:<br class=""><br class="">On 03/19/2015 05:42 PM, Anders Glans wrote:<br class=""><blockquote type="cite" class="">env LD_RUN_PATH=/System/Library/Perl/5.18/darwin-thread-multi-2level/CORE cc -mmacosx-version-min=10.10 -arch x86_64 -arch i386 -bundle -undefined dynamic_lookup -fstack-protector -o src/Ifeffit.dylib src/ifeffit_wrap.o<br class="">Simple test for presence of gnuplot ---> found it!  Using gnuplot with the x11 terminal.<br class="">Building Demeter<br class="">Building Artemis User's Guide<br class="">Building Athena User's Guide<br class="">copying src/Ifeffit.so to /Users/Anders/perl/auto/Ifeffit/Ifeffit.so<br class=""></blockquote><br class="">It seems that my build script is too stupid to know that the shared<br class="">object library built from the ifeffit wrapper is called .dylib and not<br class="">.so.<br class=""><br class="">Try copying "src/Ifeffit.dylib" to "/Users/Anders/perl/auto/Ifeffit/"<br class="">by hand, then doing "./Build" again.<br class=""><br class="">Perhaps oddly, I am not worried about that whole slew of warnings.  I<br class="">don't think they matter.<br class=""><br class="">Hopefully with the .dylib file in the correct location, this<br class=""><br class="">  t/000_ifeffit.t ......... Can't load<br class="">'/Library/Perl/5.18/darwin-thread-multi-2level/auto/Ifeffit/Ifeffit.bundle'<br class="">  for module Ifeffit:<br class=""><br class="">and so on, won't happen.<br class=""><br class="">Fingers crossed!<br class="">B<br class=""><br class="">-- <br class=""> Bruce Ravel  ------------------------------------ <a href="mailto:bravel@bnl.gov" class="">bravel@bnl.gov</a><br class=""><br class=""> National Institute of Standards and Technology<br class=""> Synchrotron Science Group at NSLS-II<br class=""> Building 535A<br class=""> Upton NY, 11973<br class=""><br class=""> Homepage:    <a href="http://bruceravel.github.io/home/" class="">http://bruceravel.github.io/home/</a><br class=""> Software:    <a href="https://github.com/bruceravel" class="">https://github.com/bruceravel</a><br class=""> Demeter:     <a href="http://bruceravel.github.io/demeter/" class="">http://bruceravel.github.io/demeter/</a><br class="">_______________________________________________<br class="">Ifeffit mailing list<br class=""><a href="mailto:Ifeffit@millenia.cars.aps.anl.gov" class="">Ifeffit@millenia.cars.aps.anl.gov</a><br class="">http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit<br class=""></div></blockquote></div><br class=""></div></body></html>