<html dir="ltr"><head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style id="owaTempEditStyle"></style><style title="owaParaStyle"><!--P {
        MARGIN-TOP: 0px; MARGIN-BOTTOM: 0px
}
--></style>
</head>
<body ocsi="x">
<div style="FONT-FAMILY: Tahoma; DIRECTION: ltr; COLOR: #000000; FONT-SIZE: x-small">
<div></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">Dear mailing list user,</font></div>
<div dir="ltr"><font face="tahoma"></font> </div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">When running an example file of Larch-0.9.24 with Python2 on Ubuntu x86_64, the following error was reported.</font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">  File "Py_usinglarch.py", line 32, in <module></font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">    autobk(xafsdat.energy, xafsdat.mu, rbkg=1.0, _larch=my_larch)</font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">  File "/usr/local/lib/python2.7/dist-packages/larch/__init__.py", line 37, in wrapper</font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">    return fcn(*args, **keywords)</font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">  File "/usr/share/larch/plugins/xafs/autobk.py", line 187, in autobk</font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">    fit.leastsq()</font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">  File "/usr/local/lib/python2.7/dist-packages/larch/fitting/minimizer.py", line 395, in leastsq</font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">    lsout = leastsq(self.__residual, self.vars, **lskws)</font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">  File "/usr/local/lib/python2.7/dist-packages/larch/fitting/minimizer.py", line 222, in leastsq</font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">    shape, dtype = _check_func('leastsq', 'func', func, x0, args, n)</font></div>
<div dir="ltr"><font color="#000000" size="2" face="Tahoma">ValueError: need more than 1 value to unpack</font></div>
<font color="#000000" size="2" face="Tahoma">
<div dir="ltr"><br>
Is Larch-0.9.24 compatible with Python2 on Ubuntu x86_64? If not, what packages and dependencies could we install to make it work on Python2? Or is Larch-0.9.24 only compatible with Python3?</div>
<div dir="ltr"> </div>
<div dir="ltr">Many thanks in advance,</div>
<div dir="ltr">Matthias</font></div>
</div>
</body>
</html>