<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=Windows-1252">
</head>
<body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">
On Oct 7, 2014, at 1:29 PM, Bruce Ravel <<a href="mailto:bravel@bnl.gov">bravel@bnl.gov</a>> wrote:<br>
<div><br class="Apple-interchange-newline">
<blockquote type="cite">On 10/07/2014 02:43 PM, Schima, Frank wrote:<br>
<blockquote type="cite">Iím going to need specific steps to reproduce the issue.<br>
</blockquote>
<br>
As I understood the issue from Ellen's first message, the problem is that Athena is not able to find the modules "PDL::Lite" (which should be installed when "PDL" is installed) and/or "PDL::Stats::GLM".<br>
<br>
If I force Athena to fail to load one of them, then selecting "Principle Components Analysis" from the main menu will look like the first attachment.<br>
<br>
If Athena can find those two modules, the selecting "Principle Components Analysis" will look like the second attachment.<br>
<br>
The test in Athena is really simple.  If those two modules can be loaded successfully, then the PCA tool will display properly.  If not, that message is the graceful fall back.  My guess is that one or both of those perl modules is not being found on Ellen's
 computer.<br>
<br>
A simple way to test from the command line whether the modules can be loaded is to do<br>
<br>
   perl -e 'use PDL::Lite'<br>
or<br>
   perl -e 'use PDL::Stats::GLM'<br>
<br>
If they cannot be found, then perl spits up an error message.  If  they can, then nothing happens.<br>
</blockquote>
<div><br>
</div>
<div>Nothing happens for me. So they are installed. At this point it looks like an issue with her Macports install. </div>
<div><br>
</div>
<div>I would start by verifying that she is correctly using perl 5.16 in Macports. What is the output of the following?</div>
<div><br>
</div>
<div><font face="Monaco">$ port installed perl5<br>
</font><br>
</div>
<div>Here is my output. </div>
<div><br>
</div>
<div><font face="Monaco">The following ports are currently installed:<br>
  perl5 @5.12.4_0+perl5_16 (active)</font></div>
<div><br>
</div>
<div>Then the Macports perl needs to be in your path. What is the output of the following?</div>
<div><br>
</div>
<div><font face="Monaco">$ echo $PATH<br>
</font><br>
</div>
<div>My output is:</div>
<div><br>
</div>
<div><font face="Monaco">/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin<br>
</font><br>
</div>
<div><br>
</div>
Cheers!</div>
<div>Frank</div>
<div><br>
<blockquote type="cite"><br>
B<br>
<br>
-- <br>
Bruce Ravel  ------------------------------------ <a href="mailto:bravel@bnl.gov">
bravel@bnl.gov</a><br>
<br>
National Institute of Standards and Technology<br>
Synchrotron Science Group at NSLS --- Beamlines U7A, X24A, X23A2<br>
Building 535A<br>
Upton NY, 11973<br>
<br>
Homepage:    <a href="http://bruceravel.github.io/home/">http://bruceravel.github.io/home/</a><br>
Software:    <a href="https://github.com/bruceravel">https://github.com/bruceravel</a><br>
Demeter:     <a href="http://bruceravel.github.io/demeter/">http://bruceravel.github.io/demeter/</a><br>
<span><pca_wrong.png></span><span><pca_right.png></span>_______________________________________________<br>
Ifeffit mailing list<br>
<a href="mailto:Ifeffit@millenia.cars.aps.anl.gov">Ifeffit@millenia.cars.aps.anl.gov</a><br>
http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit<br>
</blockquote>
</div>
<br>
</body>
</html>