<div dir="ltr">Hi Andrei,<br><br><div class="gmail_extra">This might be relevant:<br>  <a href="http://search.cpan.org/~adamk/Archive-Zip-1.31_01/lib/Archive/Zip.pm#Archive::Zip_Global_Variables" target="_blank">http://search.cpan.org/~adamk/Archive-Zip-1.31_01/lib/Archive/Zip.pm#Archive::Zip_Global_Variables</a><br>


</div><div class="gmail_extra"><br></div><div class="gmail_extra">While I understand "I am not an expert in programming", one of the key features of Demeter is that you can edit the source. Armed with the log message you sent, and the documentation above, here's a suggestion: Edit the file<br>


 C:/strawberry/perl/site/lib/Demeter/UI/Artemis.pm<br>so that, near the top it reads:<br><br>use Archive::Zip qw( :ERROR_CODES :CONSTANTS );<br>$Archive::Zip::UNICODE = 1;<br><br></div><div class="gmail_extra">That should tell the Zip module (which seems to be what is unable to handle the unicode string for your path) to use unicode for the path. The document linked above suggests it might not work, which we can choose to read it optimistically as "it might work". <br>

<br></div><div class="gmail_extra">Of course, let Bruce know if that works. <br></div><div class="gmail_extra">Cheers,<br><br></div><div class="gmail_extra">--Matt<br><br></div><div class="gmail_extra"><br><br></div><div class="gmail_extra">


<div class="gmail_quote">On Fri, Sep 6, 2013 at 11:17 AM, Andrei Shiryaev <span dir="ltr"><<a href="mailto:a_shiryaev@mail.ru" target="_blank">a_shiryaev@mail.ru</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">



<div>Dear Bruce,<br><br>I have a problem with running Demeter on non-unicode Win7/64 bit computer. The log file is attached. I am using the latest update and it is better than previous versions since at least something is happening, when I've tried previous Demeter versions, they just crashed immediately.<br>


<br>I am not an expert in programming, but I suspect that similar problem existed in one of the old version of IFEFFIT as was discussed with you in July 2008 in the mail list:<br><br>===============<br><pre>A followup to the unicode issue:

I use a tool called PerlApp to build stand-alone windows executables
of my codes.  While researching how it handles temporary directory
creation, I came across the following:

  <a href="http://bugs.activestate.com/show_bug.cgi?id=43697" rel="nofollow" target="_blank">http://bugs.activestate.com/show_bug.cgi?id=43697</a>

It would seem that the issue Kleper and Shiryaev are seeing is the
result of that bug, which has been resolved in recent versions of
PerlApp.  I was certainly using a version of PerlApp that showed this
problem when the previous installer was made.

I am now using version 7.2, so things should work fine for non-ascii
language speakers.  I will communicate with Kleper and Shiryaev off
the list to ask them to test the new installer.

Regards,
B</pre>==============<br><br>I would appreciate some advice how to handle the problem.<br>Regards,<br>Andrei<br>

<br><hr><span><font color="#888888">
<br>-- <br>Andrei Shiryaev<br></font></span></div>
<br>_______________________________________________<br>
Ifeffit mailing list<br>
<a href="mailto:Ifeffit@millenia.cars.aps.anl.gov" target="_blank">Ifeffit@millenia.cars.aps.anl.gov</a><br>
<a href="http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit" target="_blank">http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit</a><br>
<br></blockquote></div><br><br clear="all"><br>-- <br>--Matt Newville <newville at <a href="http://cars.uchicago.edu" target="_blank">cars.uchicago.edu</a>> <a href="tel:630-252-0431" value="+16302520431" target="_blank">630-252-0431</a><br>


</div></div>