[Ifeffit] Artemis fit error - chi-square and R-factors are always equal to 0

Ava Rajh ava.rajh at ijs.si
Sat Mar 27 14:54:25 CDT 2021

HI, I hope I am replying to the thread correctly.

Thank you for your insights, I have spent a lot of time tinkering with 
installation and I have a partial solution. To first answer your 
- yes, the fit ran ok and comparing it to the same fit using ifeffit 
(done by a a machine using ifeffit that works correctly), the calculated 
parameters are almost the same, with slight differences of 10-5 order of 
magnitude. The plot after the fit also looks fine.
-the log I attached was from the example Cu data set, but the issue 
happens on every fit I try to run.
-I'm not sure about the feff.dat file used, I haven't been able to 
locate it in my installation.
- Feff6 (or Feff6l if I set it in preferences) are able to run as far as 
I can tell
-I have run the example larch scripts to which you pointed me, and most 
of them were able to run ok, with no obvious issues (the parameters 
looked ok and reduced chi-square and R vales were reported). There was 
an error in running a few of the tests something to do with PlotDisplay, 
but I'm pretty sure these aren't related issues.

To me, all of this points to some trouble Artemis has communicating with 
larch. I have tried downgrading the installation from 0.9.50 (that 
installs with pip) to 0.9.49 (that the website says is the current) and 
an even older ones but no luck.

The solution war disappointingly trivial: If I completely removed larch 
and demeter suite along with everything else I installed in the last few 
days, from my computer and tried to compile it again, this time with 
ifeffit, I finally managed to get the reduced-chi square and R values. I 
have no idea why it didn't work when I tried it a few times before 
before but now I am able to get the fit and all required parameters. It 
still doesn't work with larch, but for now, at least I'm able to get the 
results. I'll re-install Larch and tinker with it a bit more to try to 
figure out where the error was coming from and report back if I find 
anything that might help someone else facing the same issue.

Thanks again for the help
Best, Ava

More information about the Ifeffit mailing list