[Ifeffit] Cannot start larch on ubuntu 20.04.2 LTS

Don Baker, Dr. don.baker at mcgill.ca
Mon Jun 28 12:37:22 CDT 2021

Hi Folks,

I think I am missing something obvious and am hoping that you can quickly tell me my mistake, so let me begin my story:

I downloaded xraylarch-2021-060Linux-x86_64.sh into downloads on a Asus Zenbook using ubuntu 20.04.2 LTS
I ran the command bash ./xraylarch-2021-060Linux-x86_64.sh
Larch appears to have been correctly installed, but because I am using a gnome desktop no shortcuts appeared on my desktop (as promised) ,and there were no files that       I could identify as shortcuts in my Downloads directory (which was set to display hidden files)
I then moved to the /xraylarch/bin and tried to launch larch using python and this is what happened:

python larch
Traceback (most recent call last):
  File "larch", line 5, in <module>
    from larch.apps import run_larch
  File "/home/donb/xraylarch/lib/python3.8/site-packages/larch/__init__.py", line 52, in <module>
    from . import builtins
  File "/home/donb/xraylarch/lib/python3.8/site-packages/larch/builtins.py", line 27, in <module>
    from . import xrd
  File "/home/donb/xraylarch/lib/python3.8/site-packages/larch/xrd/__init__.py", line 25, in <module>
    from .amscifdb import CifStructure, get_amscifdb, get_cif, find_cifs
  File "/home/donb/xraylarch/lib/python3.8/site-packages/larch/xrd/amscifdb.py", line 40, in <module>
    from pymatgen.io.cif import CifParser
  File "/home/donb/xraylarch/lib/python3.8/site-packages/pymatgen/io/cif.py", line 25, in <module>
    from pymatgen.core.composition import Composition
  File "/home/donb/xraylarch/lib/python3.8/site-packages/pymatgen/core/__init__.py", line 21, in <module>
    from .lattice import Lattice  # noqa
  File "/home/donb/xraylarch/lib/python3.8/site-packages/pymatgen/core/lattice.py", line 23, in <module>
    from pymatgen.util.coord import pbc_shortest_vectors
  File "/home/donb/xraylarch/lib/python3.8/site-packages/pymatgen/util/coord.py", line 17, in <module>
    from . import coord_cython as cuc
  File "pymatgen/util/coord_cython.pyx", line 1, in init pymatgen.util.coord_cython
ValueError: numpy.ndarray size changed, may indicate binary incompatibility. Expected 88 from C header, got 80 from PyObject

I also tried to use python to start larch_server and xas_viewer and had the same results.  I also have the same results if I try to launch larch using ./larch

This is the information on the version of Python that I am running:
Python 3.8.10 (default, Jun  4 2021, 15:09:15)
[GCC 7.5.0] :: Anaconda, Inc. on linux
Type "help", "copyright", "credits" or "license" for more information.

Any suggestions anyone has to offer will be appreciated.

Wishing you all the best,



Melting rocks today for a better tomorrow . . .
Don R. Baker, Professor of Geochemistry, McGill University
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20210628/6adbca7f/attachment.htm>

More information about the Ifeffit mailing list