[Ifeffit] trouble installing Demeter from source on Ubuntu 18.04

Joseph Zsombor-Pindera joseph.zpindera at gmail.com
Mon Oct 14 06:21:25 CDT 2019

Dear mailing list members;

I'm trying to build Demeter from source according to Bruce Ravel's guide
I have mostly been able to install the dependencies, but I had trouble with
the libwxgtk packages, so I installed 3.1.0 according to these
wx-config --version results in: 3.1.0, so I think it's installed correctly.
libgif4 is no longer in the repository, so I installed libgif-dev and
libgif7. WxPerl 0.9932 is installed. Iffeffit is installed, and gnuplot-x11
and pgplot5 are installed. I ran ./Build installdeps and it ran but
eventually got stuck in a loop saying "please tell me where I can find your
apache src", which I ignored. The script terminated with "/usr/bin/make
install  -- OK" and then I installed apache2 anyways. Now, if I rerun it,
it outputs "all prerequisites satisfied". I ran perl Build.PL, which seemed
to complete successfully, and then finally ./Build and ./Build test,
however ./Build test fails one test:

Test Summary Report-------------------
t/003_config.t (Wstat: 512 Tests: 22 Failed: 2)
Failed tests: 17, 22
Non-zero exit status: 2
Files=44, Tests=2671, 89 wallclock secs ( 0.34 usr 0.07 sys + 85.03 cusr
3.94 csys = 89.38 CPU)
Result: FAIL
Failed 1/44 test programs. 2/2671 subtests failed.

corresponding to:

#   Failed test 'configuration system introspection works: groups 38
#   at t/003_config.t line 66.

#   Failed test 'introspection after reading new group: groups'
#   at t/003_config.t line 80.
# Looks like you failed 2 tests of 22.
t/003_config.t .......... Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/22 subtests

line 80 in demeter/t/003_config.t is:
ok( ($#groups == $number_of_groups), 'introspection after reading new
group: groups');

I'm not sure what's going wrong here. Does anyone know how to resolve this

any help would be much appreciated,

*Joseph Zsombor-Pindera, BSc*
PhD Student, UBC Chemistry
Cell:  514.804.0798
6201 Cecil Green Park Road
Vancouver BC, V6T 1Z1

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20191014/ee362d91/attachment.html>

More information about the Ifeffit mailing list