[Ifeffit] Data Import Bug (Athena 0.9.26)

Beck, Aaron (INE) aaron.beck at kit.edu
Fri Apr 5 08:46:43 CDT 2019

Dear Adam and Mailing List,

I experienced this problem in Athena 0.9.26, only when you import raw data in keV. It seems to me that Athena somehow sets all stepsizes between different points to the largest stepsize you have in your scan – as far as I remember I didn’t have any trouble for scans with only one stepsize. The workaround described by Lucy to convert the raw data into eV (using Excel or any other program) before importing to Athena worked for me as well. Also using an older Athena version (e.g. 0.9.25) worked for me.
The bug has already been discussed in the mailing list last year. Maybe you can find some useful information via the following archive link as well: https://www.mail-archive.com/ifeffit@millenia.cars.aps.anl.gov/msg06272.html

Best regards,
Aaron Beck

From: Ifeffit [mailto:ifeffit-bounces at millenia.cars.aps.anl.gov] On Behalf Of Lucy M Mottram
Sent: Friday, April 05, 2019 3:19 PM
To: XAFS Analysis using Ifeffit
Subject: Re: [Ifeffit] Data Import Bug (Athena 0.9.26)

Dear Adam and Mailing List,

I've checked and found some of my data has a similar problem, I don't know how to solve this using settings in Athena, however as a workaround I have found that if I convert the energy in my raw data file from KeV to Ev before importing it into Athena (using excel) it appears that re-sampling issue does not occur. Hopefully that helps in the short term and gives a clue to what is going wrong with the import.

All the best
Lucy Mottram

On Fri, 5 Apr 2019 at 12:35, Clark Adam Hugh (PSI) <adam.clark at psi.ch<mailto:adam.clark at psi.ch>> wrote:
Dear Mailing List

I have recently come across a data import error when using Athena version 0.9.26. When importing data there appears to be a resampling which significantly reduces the resolution of the data. Attached is an example dataset with an energy step of 0.5 eV on the Cu K edge. When importing with Athena 0.9.26 this data is significantly resampled resulting in an energy resolution on the edge of 1.5 eV which can either be seen by plotting or by exporting and inspecting the datafile. Using version 0.9.25 resolves this issue entirely. The data itself appears to actually be visible correctly during the import process (the import tab shows the data listed correctly when choosing which columns to import).

Is there a setting somewhere within Athena 0.9.26 that sets the default behavior to resample the imported data?

Adam Clark

Paul Scherrer Institut
Adam Hugh Clark
Forschungsstrasse 111
5232 Villigen PSI

Telefon: +41 56 310 41 51
E-Mail: adam.clark at psi.ch<mailto:adam.clark at psi.ch>
Ifeffit mailing list
Ifeffit at millenia.cars.aps.anl.gov<mailto:Ifeffit at millenia.cars.aps.anl.gov>
Unsubscribe: http://millenia.cars.aps.anl.gov/mailman/options/ifeffit
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20190405/d7fb6a01/attachment.html>

More information about the Ifeffit mailing list