[Ifeffit] using the mail list archive for mac install

Simon James s.james at florey.edu.au
Wed Jul 11 02:50:16 CDT 2018

Hi all,

I must admit that couldn’t cut it in terms of wrangling MacPorts and opted to run a windows virtual machine on my Mac and use Demeter in on the virtual machine.

This can be somewhat awkward but for the most part I’ve found this to work well enough.



This mail was composed on the move via my phone. Apologies for any typos.

Florey Institute of Neuroscience and a Mental Health
Melbourne Brain Centre
30 Royal Pde
Parkville, 3052 VIC

Office:   +61 3 9035 4260
Mobile: + 61 4 3811 0982

On 11 Jul 2018, at 4:17 pm, Schindler Karl-Michael <karl-michael.schindler at web.de<mailto:karl-michael.schindler at web.de>> wrote:

> Am 11.07.2018 um 00:44 schrieb Matt Newville <newville at cars.uchicago.edu<mailto:newville at cars.uchicago.edu>>:
> Hi Joel,
>> I ran into the problem that some people seem to have with Demeter on mac while
>> upgrading to High Sierra. I found a fix on this mail list, but…
> Yeah, Demeter on MacOS is a continuing challenge. Even when it can be installed, parts of the GUI interaction are pretty buggy (I believe this must be due to wxPerl on Mac). MacPorts seems to need a fair amount of attention and expects the end user to know Unix command line tools well enough to be able to run updates and understand and react to error messages. For sure, it is a useful resource for developers, but it seems like it is not really designed for deploying end-user software.
> ​Still​, I don't know of a better alternative for getting Demeter working on MacOS. I've tried many of the alternatives, and wxPerl seems to be a real stumbling block for all of them.
>> 1) I can’t download Template.pm<http://Template.pm> from the archive (bin file that uncompresses to cpgz file
>> that uncompresses back to a bin file…)
> I think that the advice from Luke and Bruce back in April was to try to find and install version 1.47 of Text::Template. You might find this at
> https://metacpan.org/source/MSCHOUT/Text-Template-1.47/lib/Text<https://metacpan.org/source/MSCHOUT/Text-Template-1.47/lib/Text>
> and try unpacking and installing that. There may be a way to specify particular versions with the "cpan" program, but I do not know how to do it. I don't think we want "install old version of some library" to be a long term solution (this will break other things eventually), but it might work for you.
>> 2) Matt mentions that he installed 0.9.26 from macports, but I see only 0.9.25 (stable & develop).
> To clarify, in April I updated MacPorts to the latest versions, installed the packages for Demeter 0.9.25. Then I installed Demeter 0.9.26 from source code on top of that. That might also work​, but it's probably more work than most folks would want to do.​
> ​Cheers,​
> —Matt

Just to let you know: For other reasons, I am using fink instead of MacPorts on my Mac and I tried to create a package description with that for larch, but got stuck with some of the wx… stuff. However, sooner or later, I will have another go at it. Fink has a similar barrier as macPorts, as both need an installation of Xcode. At least, there is a GUI for the installation of packages.

Michael Schindler
Ifeffit mailing list
Ifeffit at millenia.cars.aps.anl.gov<mailto:Ifeffit at millenia.cars.aps.anl.gov>
Unsubscribe: http://millenia.cars.aps.anl.gov/mailman/options/ifeffit
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20180711/65bbb1dc/attachment-0001.html>

More information about the Ifeffit mailing list