[Ifeffit] Athena with IOS "El Capitan"

Matt Newville newville at cars.uchicago.edu
Tue Feb 2 10:46:10 CST 2016


Hi Manuel,


On Mon, Feb 1, 2016 at 4:16 PM, Manuel Cossio Kohler <cossioko at ualberta.ca>
wrote:

> Hello,
>
> I am having some issues with the Athena software. After upgrading the OS
> of the macbook pro to "El Capitan" Version 10.11.3, Athena stopped working
> properly. Once the iXAFS icon was clicked nothing happened. I decided to do
> a bit of research and installed the latest verion of XQuartz version 2.7.8.
> I was able to launch athena by executting "athena" from the terminal. Up to
> that point, I figured that everything was running smoothly until I realized
> that I could prompt any plots. Something in the software or operating
> system was not allowing Athena to display plots. I would be really grateful
> if you could provide me with a solution to this problem (if there is any)
> or any advice that would allow me to process XAS data again. Thank you
>
>
>
Regards,
>
> Manuel Cossio
>
>
The iXAFS  code is very old and does not provide the latest, supported
version of Athena (et al).    I'm not surprised that plotting doesn't work,
as this relied on other old libraries/applications that may not be well
supported on 10.11.

The installation instructions at http://bruceravel.github.io/demeter/#mac
should work, especially if you've already installed XQuartz.   The
installation with MacPorts isn't quite as fast as with a disk image, but it
is straightforward, and does give the latest versions too.

--Matt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20160202/1af6a5f6/attachment-0001.html>


More information about the Ifeffit mailing list