[Ifeffit] error on installing demeter on MacOSX 10.11.6

Matt Newville newville at cars.uchicago.edu
Wed Dec 7 07:49:53 CST 2016


Hi Valerio,

Hmm, that seems like some set of packages didn't update completely.  What
does

   ~> port installed |grep  p5.24.*compress

show?  For me, it gives

  p5.24-compress-raw-bzip2 @2.69.0_0 (active)
  p5.24-compress-raw-zlib @2.69.0_0 (active)
  p5.24-io-compress @2.69.0_0 (active)

If one of these is showing a version number of "2.15", that might explain
the error.
Either way, I'd suggest doing

     ~> port upgrade outdated

Hope that helps,

--Matt


On Wed, Dec 7, 2016 at 7:24 AM, Valerio Scagnoli <valerio.scagnoli at psi.ch>
wrote:

> Dear all,
> I was trying to install demeter on my Mac with mac port and the
> installation seemed to run smoothly (after following the advice on the
> installation page!).
> However, when I try to start Athena from the command line I get the
> following error message:
> bash-3.2$ athena
> IO::Compress::Base::Common version 2.069 required--this is only version
> 2.015 at /opt/local/lib/perl5/vendor_perl/5.24/Compress/Zlib.pm line 10,
> <DATA> line 1.
> BEGIN failed--compilation aborted at /opt/local/lib/perl5/vendor_perl/5.24/Compress/Zlib.pm
> line 10, <DATA> line 1.
> Compilation failed in require at /opt/local/lib/perl5/site_
> perl/5.24/darwin-thread-multi-2level/Demeter/Files.pm line 27, <DATA>
> line 1.
> BEGIN failed--compilation aborted at /opt/local/lib/perl5/site_
> perl/5.24/darwin-thread-multi-2level/Demeter/Files.pm line 27, <DATA>
> line 1.
> Compilation failed in require at /opt/local/lib/perl5/vendor_perl/5.24/Module/Runtime.pm
> line 317, <DATA> line 1.
> Compilation failed in require at /opt/local/lib/perl5/site_
> perl/5.24/darwin-thread-multi-2level/Demeter/UI/Athena.pm line 24, <DATA>
> line 1.
> BEGIN failed--compilation aborted at /opt/local/lib/perl5/site_
> perl/5.24/darwin-thread-multi-2level/Demeter/UI/Athena.pm line 24, <DATA>
> line 1.
> Compilation failed in require at /opt/local/bin/athena line 27, <DATA>
> line 1.
> BEGIN failed--compilation aborted at /opt/local/bin/athena line 27, <DATA>
> line 1.
>
> I tried to install the following zlib packages and uninstall/reinstall
> demeter, but the error still remains.
> bash-3.2$ port installed |grep  zlib
>   p5.24-compress-raw-zlib @2.69.0_0 (active)
>   zlib @1.2.8_0+universal (active)
>
> I have the following perl package installed
> bash-3.2$ port installed |grep  perl
>   p5.24-libwww-perl @6.150.0_0+ssl (active)
>   p5.24-perl-ostype @1.10.0_0 (active)
>   p5.24-perlio-layers @0.11.0_0 (active)
>   p5.24-perlio-utf8_strict @0.6.0_0 (active)
>   perl5 @5.24.0_0+perl5_24 (active)
>   perl5.24 @5.24.0_0+universal (active)
>
> Any help will be appreciated.
> Valerio Scagnoli
>
>
>
> _______________________________________________
> Ifeffit mailing list
> Ifeffit at millenia.cars.aps.anl.gov
> http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit
> Unsubscribe: http://millenia.cars.aps.anl.gov/mailman/options/ifeffit
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20161207/28fc5974/attachment.html>


More information about the Ifeffit mailing list