[Ifeffit] *****SPAM*****Re: Athena and Artemis installation problem

Matt Newville newville at cars.uchicago.edu
Tue Oct 27 20:59:01 CDT 2015

Hi  Wuhib,

Sorry to jump in a little late.

On Mon, Oct 26, 2015 at 4:42 AM, Wuhib Tamrat <tamrat at cerege.fr> wrote:

> Hi all,
> This is with regard to an installation problem that I am facing at the
> moment on my Mac. Sorry, if this is too basic a problem and the email is
> spamming your mail box. Below are specifics of three fold problems that I
> would be happy if I could find a solution for at least one.
> *Problem1:* I am working on El Capitan (the latest Mac Operating System)
> and what I guess the problem to be is compatibility issues with the
> different required components (X11, XQuartz and  Aqua term). And may be
> with the required macports as well.
> I installed using the disk image provided on
> http://cars9.uchicago.edu/ifeffit/Downloads and had followed all the
> instructions given. I see that the latest OS available is for ‘Snow
> Leopard’ but the package works well on colleagues’ computers with latter
> versions of mac OS.
> The problem is that all get installed but when I open the software suit,
> the initial small window that has the three individual programs opens but
> what ever I do to it afterwards it does not open into anything else.
> There is also the option to choose a file. So I navigate and choose a file
> thinking it will help pushing the program to open but that leads to nowhere
> as well.
> So, I am wondering if anybody had faced similar problem installing on the
> latest versions of mac OS and has a solution.
This will absolutely not work.  No chance, don't even bother trying.  This
is a very, very outdated version of Athena/Artemis.  As you no doubt read
at the top of that Downloads page,  this is no longer supported.  The link
should probably be removed.

> *Problem 2:* Initially I tried installing the “demeter” suit via
> ‘Terminal’ as specified in the site  [http://bruceravel.github.io/demeter/].
> By writing a command on Terminal as opposed to with a disc image as in the
> case of Problem 1). My operating system at that time was Yosemite. All
> worked as explained on the website, even writing “athena” on a terminal
> window calls the program Athena.  But that is just it, no explanation as
> how to call Artemis or Hephaestus exist on the site.
> So I am wondering if the installation procedure given on the site works
> also with the other two programs and if so, is there a way to open them or
> call them via ’Terminal'.

I can't tell from this what you did at the command line.  For El Capitan
you will absolutely have to upgrade Xcode, and it's command-line tools, as
instructed in the MacPorts page referenced.

I upgraded to El Capitan this past weekend.  I upgraded Xcode and blew away
the Macports install, and tried to do a clean install of demeter with "sudo
port install demeter".  Unfortunately, the default macports install would
install from source and needs to build libgcc, gcc4.9 and gcc 5.2 all from
source.   This takes many hours.  The best word available in the English
language to describe this is "idiotic".

Macports *does* allow binary installs (port install -b).  This is faster.
  Unfortunately, I've hit snags with that too (expat, for example, fails to
build this way). I'll keep trying.   I am not convinced that Macports is a
good way to be distributing Demeter.

Has any tried building Demeter with Homebrew?  I haven't yet, but installed
several homebrew packages, including gfortran, python, many python packages
with no trouble at all.  I haven't tried building wx Perl.  But it seems
like there is no chance it can be worse than MacPorts.    I'll try that too.

> *Problem 3:* My last problem was when Athena closed unexpectedly. As most
> programs, Athena had an auto recover option which opens when it is
> restarted. But this time the auto recover option always comes up and this
> option renders the whole program inactive; “Application Not Responding”.
> Every time I open Athena, “Auto recover” option comes up and Athena become
> unresponsive. I tried updating the software in hope of changing something
> but that did not change anything. Uninstalling it is also a problem because
> there were no files that I could find to uninstall from or delete. I could
> not find the location where terminal installed the “Demeter” suit. There
is a way to delete on terminal by writing “Sudo rm-rf/file name” but that
> is not removing “demeter” either.

Wait, did Demeter get installed or not?  I cannot tell.  If you're trying
to run an older version  that will absolutely not work.

Anyway, sorry for the trouble, and I wish I had a working Demeter too.
I'll keep trying....

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20151027/3065fce9/attachment.html>

More information about the Ifeffit mailing list