[Ifeffit] Athena and Artemis installation problem

Wuhib Tamrat tamrat at cerege.fr
Mon Oct 26 10:33:50 CDT 2015


I am assuming the obvious way to execute “Artemis” and “Hephaestus” you were talking about would be to do the same thing as “Athena”; that is to type the name of the software and execute. But, I have tried that for both and it did not work. So I will wait for a response from a Mac expert on that.

And when the program becomes unresponsive you guessed error messages might be displayed on the terminal window which I neglected to include in my previous mail. But no error messages exist.

Thank you

Wuhib


> On 26 Oct 2015, at 14:35, Bruce Ravel <bravel at bnl.gov> wrote:
> 
> 
> I am going to preface this comment, as I do with many about the Mac
> package, by reminding you that I do not own a Mac and do not have any
> personal experience running my own software on a Mac.  The Mac package
> is graciously maintained by Joe Fowler, not because it is in his job
> description to do so, but because he is a good and helpful guy.
> 
> 
>> _Problem 2:_ Initially I tried installing the “demeter” suit via
>> ‘Terminal’ as specified in the site
>>  [http://bruceravel.github.io/demeter/]. By writing a command on
>> Terminal as opposed to with a disc image as in the case of Problem 1).
>> My operating system at that time was Yosemite. All worked as explained
>> on the website, even writing “athena” on a terminal window calls the
>> program Athena.  But that is just it, no explanation as how to call
>> Artemis or Hephaestus exist on the site.
>> So I am wondering if the installation procedure given on the site works
>> also with the other two programs and if so, is there a way to open them
>> or call them via ’Terminal'.
> 
> So .... do I understand this correctly?  The program "Athena" is
> executed by typing "athena" at the command line and your question is
> about how to start "Artemis" or "Hephaestus"?
> 
> I would think that the answer was obvious, but perhaps one of the Mac
> users on the list could weight in.
> 
> 
>> _Problem 3:_ My last problem was when Athena closed unexpectedly. As
>> most programs, Athena had an auto recover option which opens when it is
>> restarted. But this time the auto recover option always comes up and
>> this option renders the whole program inactive; “Application Not
>> Responding”. Every time I open Athena, “Auto recover” option comes up
>> and Athena become unresponsive. I tried updating the software in hope of
>> changing something but that did not change anything. Uninstalling it is
>> also a problem because there were no files that I could find to
>> uninstall from or delete. I could not find the location where terminal
>> installed the “Demeter” suit. There is a way to delete on terminal by
>> writing “Sudo rm-rf/file name” but that is not removing “demeter” either.
> 
> If you start Athena from the terminal, it should write error messages
> to the terminal when it runs into problems.  This is explained in some
> detail here: http://bruceravel.github.io/demeter/pods/bugs.pod.html
> and here: http://bruceravel.github.com/demeter/pods/help.pod.html
> 
> A useful, actionable bug report would include those error messages,
> which tend to be a lot more helpful for me than this sort of
> narrative, which is hard for me to understand.
> 
> B
> 
> -- 
> Bruce Ravel  ------------------------------------ bravel at bnl.gov
> 
> National Institute of Standards and Technology
> Synchrotron Science Group at NSLS-II
> Building 535A
> Upton NY, 11973
> 
> Homepage:    http://bruceravel.github.io/home/
> Software:    https://github.com/bruceravel
> Demeter:     http://bruceravel.github.io/demeter/
> _______________________________________________
> Ifeffit mailing list
> Ifeffit at millenia.cars.aps.anl.gov
> http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit





More information about the Ifeffit mailing list