[Ifeffit] Athena and Artemis installation problem

Wuhib Tamrat tamrat at cerege.fr
Mon Oct 26 04:42:15 CDT 2015

Hi all, 
This is with regard to an installation problem that I am facing at the moment on my Mac. Sorry, if this is too basic a problem and the email is spamming your mail box. Below are specifics of three fold problems that I would be happy if I could find a solution for at least one.

Problem1: I am working on El Capitan (the latest Mac Operating System) and what I guess the problem to be is compatibility issues with the different required components (X11, XQuartz and  Aqua term). And may be with the required macports as well.
I installed using the disk image provided on http://cars9.uchicago.edu/ifeffit/Downloads <http://cars9.uchicago.edu/ifeffit/Downloads> and had followed all the instructions given. I see that the latest OS available is for ‘Snow Leopard’ but the package works well on colleagues’ computers with latter versions of mac OS.
The problem is that all get installed but when I open the software suit, the initial small window that has the three individual programs opens but what ever I do to it afterwards it does not open into anything else.
There is also the option to choose a file. So I navigate and choose a file thinking it will help pushing the program to open but that leads to nowhere as well.
So, I am wondering if anybody had faced similar problem installing on the latest versions of mac OS and has a solution.

Problem 2: Initially I tried installing the “demeter” suit via ‘Terminal’ as specified in the site  [http://bruceravel.github.io/demeter/ <http://bruceravel.github.io/demeter/>]. By writing a command on Terminal as opposed to with a disc image as in the case of Problem 1). My operating system at that time was Yosemite. All worked as explained on the website, even writing “athena” on a terminal window calls the program Athena.  But that is just it, no explanation as how to call Artemis or Hephaestus exist on the site.  
So I am wondering if the installation procedure given on the site works also with the other two programs and if so, is there a way to open them or call them via ’Terminal'.

Problem 3: My last problem was when Athena closed unexpectedly. As most programs, Athena had an auto recover option which opens when it is restarted. But this time the auto recover option always comes up and this option renders the whole program inactive; “Application Not Responding”. Every time I open Athena, “Auto recover” option comes up and Athena become unresponsive. I tried updating the software in hope of changing something but that did not change anything. Uninstalling it is also a problem because there were no files that I could find to uninstall from or delete. I could not find the location where terminal installed the “Demeter” suit. There is a way to delete on terminal by writing “Sudo rm-rf/file name” but that is not removing “demeter” either.

And yes, I have consulted the IT/informatics people at my institution and they were no help.
I thank you in advance for any suggestion or similar experience sharing. And also for baring with me reading this long mail.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20151026/43a09401/attachment.html>

More information about the Ifeffit mailing list