[Ifeffit] Unable to export flattened normalized XANES spectra from Athena 0.9.24

Bruce Ravel bravel at bnl.gov
Tue Dec 8 21:15:19 CST 2015

Here's what the manual has to say


Looking at the code, however, it seems the document has swapped columns 
2/3 and columns 4/5.  I think what you are looking for is in column 4, 
not column 2.  If that's right, I'll treat this as a documentation bug. 
  If that is not the case, then I'll prod you for more information so I 
can understand the software bug.

In either case, thanks for the report.


On 12/08/2015 06:09 PM, Jeff Catalano wrote:
> I am looking for some help with a possible error on my part or bug
> associated with exporting normalized mu(E) spectra from Athena 0.9.24
> 64-bit on Windows 10 Pro 64-bit. I have some Si XANES data with a
> challenging background shape that is well removed through careful
> normalization in Athena, as long as the "Flatten normalized data" option
> is checked. When I save the current group as norm(E), what is saved is
> the non-flattened normalized data. The checkbox for flattening the data
> has no effect on what is exported despite changing what is plotted. I
> have verified this by comparing the files exported the the flatten box
> checked or unchecked. I have tried this with multiple data files loaded
> in multiple formats (raw beamline data, simple two-column E and mu data,
> PRJ files) and the effect is always the same. It is also unaffected by
> the normalization ranges I select. No matter what options I select
> Athena 0.9.24 will only save non-flattened norm(E) data.
> This behavior is different from what I remember, and I have verified
> that in version 0.8 of Athena the exported norm(E) was the flattened
> data, provided that the flatten box was checked (of course). I have been
> unable to determine if I have any errors in the settings in version
> 0.9.24 but all parameters that I can find are identical in both 0.9.24
> and 0.8. I have also uninstalled and reinstalled Athena 0.9.24 and the
> effect is still the same. Has anyone else noticed this problem? Is this
> a bug?
> Thank you,
> Jeff

  Bruce Ravel  ------------------------------------ bravel at bnl.gov

  National Institute of Standards and Technology
  Synchrotron Science Group at NSLS-II
  Building 535A
  Upton NY, 11973

  Homepage:    http://bruceravel.github.io/home/
  Software:    https://github.com/bruceravel
  Demeter:     http://bruceravel.github.io/demeter/

More information about the Ifeffit mailing list