[Ifeffit] Problems installing demeter in Manjaro Linux

Ramiro Moreira Toja rmtoja at openmailbox.org
Thu Apr 16 10:13:52 CDT 2015


Bruce,

force-installing with cpan did the trick, thanks!
I still wonder if the apache/src thing may give me trouble some day. 
When installing the XMLRPC::Lite module, I hit on that again, but 
everything worked in the end.

Thanks for your help (and for this great software, too!)

Ramiro

    I'm not familiar with Manjaro.  Are there package in its packaging
    system for those two perl modules?  If so, just install them that way.

    If not, you could try running the cpan program and doing:

        force install Regexp::Assemble

    and

        force install XMLRPC::Lite


    Another option is to download those two packages from metacpan.org and
    install them by hand.
    As for the pgplot installation -- I believe I had to do the same thing
    the last time I built Ifeffit.  Glad you figured it out!

    Good luck!  Let us know if you run into other problems.
    B




On 04/15/2015 09:40 PM, Ramiro Moreira Toja wrote:

    Hi,

    I'm using Manjaro 0.8.12 x64. I tried to install the demeter collection
    (following these instructions
    <https://bruceravel.github.io/demeter/pods/installation.pod.html>), but
    keep failing to do so. Also, I've checked to have installed all the
    reccomended packages, including apache and gnuplot.
    When installing PGPLOT, I've had to edit the configuration to use gif
    instead of png, because it kept failing to install. Once I did this, it
    went smoothly. I add this piece of information here hoping this helps to
    solve later problems.
    I'm having a little trouble installing dependencies. At the "sudo
    ./Build installdeps", it kept having trouble to find the apache/src.
    After a little Web search, it seems like I need to manually download the
    httpd sources, so I got them from here
    <http://apache.xfree.com.ar//httpd/httpd-2.4.12.tar.bz2>, but now it
    indicates I need Apache 1.3.0 version!

    If I do "perl Build.PL", I get:

    perl Build.PL
    Checking prerequisites...
        requires:
          !  Regexp::Assemble is not installed
          !  XMLRPC::Lite is not installed

    ERRORS/WARNINGS FOUND IN PREREQUISITES.  You may wish to install the
    versions
    of the modules indicated above before proceeding with this installation

    So, I guess I'm having some more problems with the dependencies, apart
    from the Apache ones.
    What should be my next move to fix this? I've been even considering
    using a Ubuntu LiveUSB with persistence, just to get this working in a
    proven system, but really would like to get it working on my OS of choice.

    Thanks in advance

    Ramiro


    _______________________________________________
    Ifeffit mailing list
    Ifeffit at millenia.cars.aps.anl.gov
    http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit

--
  Bruce Ravel  ------------------------------------ bra... at bnl.gov

  National Institute of Standards and Technology
  Synchrotron Science Group at NSLS-II
  Building 535A
  Upton NY, 11973

  Homepage:http://bruceravel.github.io/home/
  Software:https://github.com/bruceravel
  Demeter:http://bruceravel.github.io/demeter/
_______________________________________________
Ifeffit mailing list
Ifeffit at millenia.cars.aps.anl.gov
http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20150416/3740d40d/attachment.html>


More information about the Ifeffit mailing list