[Ifeffit] Artemis closes when I try to open a project file or import data

Kurinji Krishnamoorthy kurinjikrishnamoorthy2013 at u.northwestern.edu
Tue Oct 21 11:04:20 CDT 2014

I am running Demeter 0.9.20(64 bit) on Windows 8.1. The error report in the
log file when I try to open any project in Artemis is :

Started at 2014-10-21T10:19:08
Win8Home Premium (64-bit) 6292002007681

c:\Program Files (x86)\Intel\iCLS Client\;c:\Program Files\Intel\iCLS
Files (x86)\Intel\OpenCL SDK\3.0\bin\x86;C:\Program Files
(x86)\Intel\OpenCL SDK\3.0\bin\x64;C:\Program Files\Intel\Intel(R)
Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management
Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management
Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management
Engine Components\IPT;C:\Program Files (x86)\Windows Live\Shared;C:\Program

perl version: v5.18.2


Syntax error at line 1: '

                                                                    ' at
C:/strawberry/perl/site/lib/Config/INI/Reader.pm line 268, <GEN717> line 1.
IO::File=GLOB(0x13ca34f0)) called at
C:/strawberry/perl/site/lib/Config/INI/Reader.pm line 120
IO::File=GLOB(0x13ca34f0)) called at
C:/strawberry/perl/site/lib/Mixin/Linewise/Readers.pm line 103
Mixin::Linewise::Readers::__ANON__() called at
C:/strawberry/perl/site/lib/Demeter/MRU.pm line 40
Demeter::MRU::push_mru("Demeter", "artemis",
"C:\\Users\\Kurinji\\Desktop\\Kurinji\\Data\\Artemis projects\\goldfo"...)
called at C:/strawberry/perl/site/lib/Demeter/UI/Artemis/Project.pm line 473
Demeter::UI::Artemis::Project::read_project(HASH(0xdacae48)) called at
C:/strawberry/perl/site/lib/Demeter/UI/Artemis.pm line 966
Wx::CommandEvent=SCALAR(0x13342bf8)) called at
C:/strawberry/perl/site/lib/Demeter/UI/Artemis.pm line 425
Wx::CommandEvent=SCALAR(0x13342bf8)) called at
C:\strawberry\perl\site\bin\dartemis.bat line 51
eval {...} called at C:\strawberry\perl\site\bin\dartemis.bat line 51

The problem began to occur when I updated my operating system. Prior to the
update, the program was running fine but after the update, it refused to
open any project files( Both Artemis project files and Athena project
files). I am attaching a project file which I am unable to open.

Thank you!

On Tue, Oct 21, 2014 at 8:51 AM, Matt Newville <newville at cars.uchicago.edu>

> Kurinji,
> Could this be similar to the conversation discussed at
> http://millenia.cars.aps.anl.gov/pipermail/ifeffit/2014-August/012075.html
> ?
> It does appear quite possible to "break" an Artemis project file in such a
> way that it cannot be re-opened by Artemis.    This can happen if one does
> a fit and then re-runs Feff.    I don't know enough about the layout of the
> project files to know why this happens.
> But, it would be most helpful if you gave more details (like, what
> operating system and Artemis version your using) and included a project
> file that showed the problem.
> --Matt
> On Mon, Oct 20, 2014 at 10:31 PM, Kurinji Krishnamoorthy <
> kurinjikrishnamoorthy2013 at u.northwestern.edu> wrote:
>> Hi,
>> Artemis had been working well on my laptop for a while. But today when I
>> attempted to open a saved project file ( with a *.fpj extension), the
>> program tried to open it for a while but then ultimately closed without any
>> error messages. A similar thing occurred when I tried to import an Athena
>> data file into Artemis. I was wondering if anybody had any idea how to fix
>> this problem?
>> Thanks,
>> Kurinji
>> _______________________________________________
>> Ifeffit mailing list
>> Ifeffit at millenia.cars.aps.anl.gov
>> http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit
> _______________________________________________
> Ifeffit mailing list
> Ifeffit at millenia.cars.aps.anl.gov
> http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20141021/ef0ac356/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: goldfoilsuccess.fpj
Type: application/octet-stream
Size: 1434638 bytes
Desc: not available
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20141021/ef0ac356/attachment.obj>

More information about the Ifeffit mailing list