[Ifeffit] Problems with Athena

Bruce Ravel bravel at bnl.gov
Thu Oct 2 07:42:32 CDT 2014

On 10/01/2014 10:58 PM, Austin Krehel wrote:
> Dear IFEFFIT Representative,

Representative??  Umm... OK.  That's me, I suppose :)

> I am a graduate student and am just now learning about EXAFS data
> plotting. I am having a problem with opening the data that I collected
> last month at Bulk-XANES line X11A (NSLS). I have tried the new and old
> versions of Athena, and they are both not reading the .001 files, which
> according to my professor, should be read since this has worked for him
> in the past on the old version.
> When I try opening the files, it says they "could not be read by ifeffit
> as a data file".
> I have attached one of the .001 files, in case that may help. And help
> or suggestions will be greatly appreciated.

Your file seems to have been altered since it was written to disk at
the beamline.  Here is what the top of the file looks like:

      XDAC V1.4 Datafile V1
      "AsFiveStd.001" created on 8/5/14 at 15:59:30 on X-11A
      Diffraction element= Si(111).  Ring energy= 2.80 GeV
      E0= 11867.00
      NUM_REGIONS= 2
      SRB= -100 -50 100
      SRSS= 5 0.5
      SPP= 2 2
      Settling time= 0.30

      Offsets= 5117.00 729.00 16629.00 0.00 0.00
      Gains= 7.00 8.00 9.00 0.00 1.00
      As Five standard edge scan sample pressed in kapton tape

              Energy            I0             I          Iref     XIA00AsK
         11766.97378   246679.0000  1503253.0000   356315.0000 
3.0000       63.0000        2.0000        1.0000       21.0000 
13.0000        6.0000        2.0000       19.0000        5.0000 
0.0000        3.0000        4.0000        2.0000

and so on.  The problem is in the line that says


and the following 12 lines.  When written at the beamline, those lines
and the one that begins with "Energy" were all on one line without any
carriage returns.

Athena relies upon Ifeffit to determine of a file can be interpreted
as data.  If Ifeffit cannot read a file, then Athena cannot (unless a
plugin is written to recognize and process the particular file).
because that line is broken up in your file, Ifeffit is unable to
interpret it.  Because of that, Athena thinks it's not data.

When I fix that problem by hand in a text editor, Athena has no issue
reading the data.

You have a few options:

   1. Edit the file by hand to fix the line that got broken up.

   2. Edit the file by hand and simply delete the problematic lines.

   3. Write a little program that does either 1. or 2. for you.

   4. Figure out what caused the file to be altered.  If I had to
      venture a guess, I would guess that you read the file in Word or
      WordPad and then software "helped" you by reformatting the file.

      If you have copies of the data exactly as written at the
      beamline, start over from scratch and don't do whatever broke up
      that line.


  Bruce Ravel  ------------------------------------ bravel at bnl.gov

  National Institute of Standards and Technology
  Synchrotron Science Group at NSLS --- Beamlines U7A, X24A, X23A2
  Building 535A
  Upton NY, 11973

  Homepage:    http://bruceravel.github.io/home/
  Software:    https://github.com/bruceravel
  Demeter:     http://bruceravel.github.io/demeter/

More information about the Ifeffit mailing list