[Ifeffit] Saving and reopening project files in Artemis 0.9.18.2 on Windows 8.0 Pro x64

Bruce Ravel bravel at bnl.gov
Fri Feb 28 09:11:13 CST 2014


On 02/28/2014 08:46 AM, Godfrey, Ian wrote:
> I'm encountering a problem whenever I save a fitting project in Artemis
> (I have tried both the "Save Project" and "Save Current Fit" options
> from the file menu) and then try to reopen it . I have only encountered
> the issue with quick first shell fits, but I haven't tried anything else
> recently. Specifically the parameters in the paths list are reset to
> their default value (while those in the GDS window are not) when I
> reopen the file and when I try and fit the data again Artemis gives a
> message that:
>
>
> /"This data file does not exist"/
>
>
> The data file has not been moved, deleted or otherwise modified on my
> computer.
>


One of the central problems here is that the error message, "This data
file does not exist", is vague and unhelpful in this context.

I am having trouble finding my way through your recipe and the data
you have provided.  As a result, I am not 100% sure what the problem
is.  However, I have a strong hunch.  You'll let me know, I hope, if
the following pans out.

I was unable to properly import your foilref.cho file into Artemis,
although I can import it into Athena just fine.  Artemis just isn't as
clever about interpreting data as Athena is.  That is because, in the
work flow that I recommend for my software, it doesn't have to be.  It
turns out that the option to import chi(k) data into Artemis is
expecting your chi(k) data to be on a uniform grid that starts at 0.

Admittedly, that's not well documented.

Your .cho file is not in the form that Artemis expects.

I am kind of astonished that things worked as well as they did for
you.  I am suspicious that the irregular chi(k) data was saved in some
way incorrectly.  When you reopened the .fpj file, it was imported
incorrectly.  Examining the contents of your .fpj file confirms that
something odd happened to the data.  Unfortunately, Demeter didn't
complain until you tried to run a new fit -- long after the problem
began.

If you simply must use VIPER's output as the input to Artemis, here is
my suggested work-around.  Import the .cho file into Athena and save
an Athena project file.  This will interpolate your data onto an even
k-grid with zero padding at the beginning.  Save the Athena project
file and import it into Artemis.

Try that and let me know if that gets you over the hurdle.

Of course, there are two other work-arounds.  The first is to use
Athena rather than VIPER to process your data.  The second is to use
VIPER rather than Artemis to analyze your data :)


I will put this issue with importing non-standard chi(k) data directly
into Artemis on the to do list, but I see it as an edge case that may
not get huge attention.

B


-- 
  Bruce Ravel  ------------------------------------ bravel at bnl.gov

  National Institute of Standards and Technology
  Synchrotron Science Group at NSLS --- Beamlines U7A, X24A, X23A2
  Building 535A
  Upton NY, 11973

  Homepage:    http://xafs.org/BruceRavel
  Software:    https://github.com/bruceravel



More information about the Ifeffit mailing list