[Ifeffit] Saving and reopening project files in Artemis 0.9.18.2 on Windows 8.0 Pro x64

Godfrey, Ian i.godfrey at ucl.ac.uk
Fri Feb 28 07:54:51 CST 2014


Dear All,


I'm encountering a problem whenever I save a fitting project in Artemis (I have tried both the "Save Project" and "Save Current Fit" options from the file menu) and then try to reopen it . I have only encountered the issue with quick first shell fits, but I haven't tried anything else recently. Specifically the parameters in the paths list are reset to their default value (while those in the GDS window are not) when I reopen the file and when I try and fit the data again Artemis gives a message that:


"This data file does not exist"


The data file has not been moved, deleted or otherwise modified on my computer.


It may be relevant that I'm not importing an Athena project into Artemis, but I'm importing a chi(k) file (*.cho) exported from Viper (https://www.cells.es/Beamlines/CLAESS/software/viper.html) (export chi(k) on original grid).


I also frequently get a "perl.exe has stopped working A problem caused the programme to stop working correctly. Windows will close the program and notify you if a solution is available" error from Windows when exiting Artemis, which could be related.


I have attached Artemis log files from running the software to both save and open a project and I have attached an example problematic project file. This got eaten by the mailing list virus checker the first time I tried to send this, so please find it here instead: https://www.dropbox.com/s/urjkw904v168n5l/foilref.fpj


To reproduce:

  *   Start Artemis
  *   File > Import > chi(k) data
  *   Import a chi(k) data file
  *   Set up a quick first shell fit
  *   Customise some of the parameter names
  *   Run a fit
  *   File > Save Current Fit or File > Save Project (as)
  *   Close Artemis
  *   Reopen the saved project file
  *   The parameter names in the paths list have been reset to their default (but those in GDS have not)
  *   Run a fit
  *   Artemis will complain that the data file is missing

If anyone has any suggestions for a workaround or knows whether this is a bug in Artemis or a problem at my end I'd be grateful to hear.


Thanks,


Ian


----

Ian Godfrey



PhD Student,

UCL/JAIST Programme,

Industrial Doctorate Centre in Molecular Modelling and Materials Science,

Department of Chemistry,

University College London.



i.godfrey at ucl.ac.uk<mailto:i.godfrey at ucl.ac.uk>

02076 794864
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20140228/d81dd831/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dartemis - loading.log
Type: application/octet-stream
Size: 1218 bytes
Desc: dartemis - loading.log
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20140228/d81dd831/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dartemis - saving.log
Type: application/octet-stream
Size: 1218 bytes
Desc: dartemis - saving.log
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20140228/d81dd831/attachment-0001.obj>


More information about the Ifeffit mailing list