[Ifeffit] Rendering of windows in Artemis and transferring paths from feff calculation

Alison Tebo agtebo at umich.edu
Sat Apr 19 07:43:32 CDT 2014


Hi Bruce,

I don't think I've changed any defaults in my colors, but I went ahead and
messed around with them to no avail--the program still looks the same.
Please let me know if there are any other tests I can run. I have tried
removing and uninstalling MacPorts and reinstalling everything and there
are no changes in the behavior.

George, thanks for reproducing the problem. I haven't seen anything like it
here on the mailing list and was beginning to think I had gone mad.

Best,
Alison


On Fri, Apr 18, 2014 at 5:32 PM, George Sterbinsky <
GeorgeSterbinsky at u.northwestern.edu> wrote:

> Hi Bruce and Alison,
>
> I am able to confirm the behavior reported by Alison (both bigger and
> lesser problems) on OSX 10.8.5. Pressing the "transfer displayed path"
> button causes Artemis to crash and the message below to print to the
> terminal.
>
> 2014-04-18 11:18:26.309 perl5.16[1309:707] *** WARNING: -[NSImage
> compositeToPoint:fromRect:operation:] is deprecated in MacOSX 10.8 and
> later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:]
> instead.
> Can't locate object method "transfer" via package "Wx::Panel" at
> /opt/local/lib/perl5/site_perl/5.16.1/darwin-thread-multi-2level/Demeter/UI/Artemis/Data.pm
> line 1126, <F> line 9.
>
>
> Best,
> George
>
>
>
>
> On Thu, Apr 17, 2014 at 3:30 PM, Bruce Ravel <bravel at bnl.gov> wrote:
>
>> On 03/24/2014 03:21 PM, Alison Tebo wrote:
>>
>>> I am running Demeter 0.9.18 installed on a Mac 10.6.8 via the (very
>>> helpful!) Macports port. I've had nearly no problems with processing my
>>> data, but Artemis appears very strange. Most of the button can't be seen
>>> and are black instead (I've attached a screenshot). The bigger problem
>>> is that once I run a Feff calculation, I can't seem to transfer the
>>> paths from the Feff Window into the Data Window (see second screenshot).
>>> The program seems to think it's doing it--there are no error messages in
>>> the log and it even makes the little graphic as it 'grabs' the path--but
>>> it never transfers it over to the Data Window.
>>>
>>> I have attached a project file where I get this error, the feff input
>>> file that I run the calculation on, and two screenshots of what Artemis
>>> looks like for me. I don't think the input and project file matter much
>>> since this happens for me even with examples from the various courses
>>> Bruce has given.
>>>
>>> Any advice would be greatly appreciated.
>>>
>>
>> Hi Alison,
>>
>> First off, I apologize that it has taken me so long to respond to this.
>>  Busy time.
>>
>> I don't quite understand the bigger problem.  This is certainly  not a
>> problem I have on other platforms.  Do other Mac users observe the same
>> behavior?
>>
>> As for the lesser problem, looking at the icons across the top in your
>> screenshots, it would seem that you are using some kind of color theme that
>> is different from a Mac out of the box.  Is that right?  If so, how does
>> the software behave if you change the theme back to the default?
>>
>> Cheers,
>> B
>>
>>
>> --
>>  Bruce Ravel  ------------------------------------ bravel at bnl.gov
>>
>>  National Institute of Standards and Technology
>>  Synchrotron Science Group at NSLS --- Beamlines U7A, X24A, X23A2
>>  Building 535A
>>  Upton NY, 11973
>>
>>  Homepage:    http://xafs.org/BruceRavel
>>  Software:    https://github.com/bruceravel
>> _______________________________________________
>> Ifeffit mailing list
>> Ifeffit at millenia.cars.aps.anl.gov
>> http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit
>>
>
>
> _______________________________________________
> Ifeffit mailing list
> Ifeffit at millenia.cars.aps.anl.gov
> http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20140419/a53b06b6/attachment.html>


More information about the Ifeffit mailing list