[Ifeffit] Bug when adding feff calculations

Georges Siddiqi gsiddiqi at gmail.com
Wed Oct 30 10:05:26 CDT 2013

sorry to spam, but I just received an automated message saying that the
attachments were blocked because of the athena file I included:

The Copper foil.fpj has been blocked,
and Quarantine entire message has been taken on 10/30/2013 9:58:21 AM.
Message details:
Sender: gsiddiqi at gmail.com;
Recipient: ifeffit at millenia.cars.aps.anl.gov;
Subject: [Ifeffit] Bug when adding feff calculations
Attachment name: Copper foil.fpj

in case the other attachments were blocked as well, I'm reattaching them.

is there a way to attach athena/artemis files without having the servers
block them?


On Wed, Oct 30, 2013 at 3:55 PM, Georges Siddiqi <gsiddiqi at gmail.com> wrote:

> Hi,
> I'd like to report 2 bugs that I have when dealing with Feff calculations.
>  One is critical (program crashes), the other is more troublesome, but i've
> found ways around it.
> OS: Windows 7, SP1
> Demeter version: 0.9.18
> *1) Critical - Trying to add single scattering paths of arbitrary
> lengths. This used to work with an older version of the program, but now,
> no matter what I do, when I add a single scattering path with any length,
> the program crashes*
> I've attached the log file (dartemis.log)*
> *
> *
> *
> How to replicate:
> -import any file (i've attached Cu.inp for ease of comparison)
> -run atoms
> -run feff
> -load an athena file (i've attached Cu foil.apj)
> -go to "Path like" tab
> -input any bond distance, and drag path over to the path list
> *-*program should crash
> This problem occurs both with cif files and inp files (and several of both
> file types have been tried), and (so far) any type of data set I try to
> import into athena. I've just chosen the attached files for their
> simplicity.
> 2) Not critical - I deal with a lot of organometallic compounds whose cif
> files correspond of only 1 absorbing atom surrounded by a network of
> non-absorbing atoms. i.e. not a regular, repeating lattice.*  *When I
> import the cif file for one of these compounds (*see attachment, schrock
> 1.cif*), the Atoms page is fine, but in the Feff page, the "potentials"
> lists the absorbing atom as ipot 0 and 1:
>   * ipot   Z      tag
>      0     74     W
>      1     74     W
>      2     8      O
>      3     7      N
>      4     6      C
>      5     1      H
> while in the atoms list, it only appears once as ipot 0.  Naturally, if I
> just click "run Feff", the program returns an error.
> My workaround to this has been to copy the atoms list into notepad, save,
> import into excel, subtract 1 from the ipot column (besides ipot 0), and
> replace the old atoms list with the corrected atoms list.  then I manually
> change the potentials to:
>   * ipot   Z      tag
>      0     74     W
>      1     8      O
>      2     7      N
>      3     6      C
>      4     1      H
> after this it works fine.
> So this isn't a big burden, after a bit of practice I've gotten pretty
> fast at editing the Feff file, but if there's some easier solution it would
> be great.
> This problem occurs with any monomeric compounds.  If I run the feff on a
> dimeric organometallic compound, there's no problems.
> Please let me know if there's any additional information I can supply that
> would help with this.
> thanks,
> Georges Siddiqi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20131030/7db95b52/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dartemis.log
Type: application/octet-stream
Size: 1234 bytes
Desc: not available
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20131030/7db95b52/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Cu.inp
Type: application/octet-stream
Size: 258 bytes
Desc: not available
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20131030/7db95b52/attachment-0001.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: schrock 1.cif
Type: chemical/x-cif
Size: 5322 bytes
Desc: not available
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20131030/7db95b52/attachment.cif>

More information about the Ifeffit mailing list