[Ifeffit] DAthena crashes when reconstructing data from PCA

Scott Calvin scalvin at sarahlawrence.edu
Wed Jun 19 11:07:44 CDT 2013

Hi Bruce and Others,

I've tried some follow-up troubleshooting.

The problem does not occur on another laptop with Windows 7 installed, so it appears to fall under some variation of your "possibility #1." I thought perhaps it might be related to some kind of resource problem (e.g. memory allocation), so I played around with giving my Parallels virtual machine various amounts of memory, processing power, etc., but nothing changed the behavior.

I would be interested to know from other people on the list if they have gotten the reconstruction of data from PCA to work under Windows 8 (I don't have another Windows 8 machine readily available to test it on). That would help narrow down whether the issue is a general one with that OS, or whether it's something more quirky having to do with the environment I'm using.

--Scott Calvin
Sarah Lawrence College

On Jun 14, 2013, at 9:18 AM, Bruce Ravel <bravel at bnl.gov> wrote:

> On 06/11/2013 09:25 PM, Scott Calvin wrote:
>> Athena is crashing every time I try to "Reconstruct Data" in the PCA
>> dialog. It doesn't seem to matter what data I use, or what space I'm
>> working in (mu or chi), or how many components I use in the
>> reconstruction.
>> I'm using Demeter 0.9.17 with Ifeffit 1.2.11d, under Windows 8
>> running in Parallels 8 running under OS 10.8.4 on a MacBook Pro.
>> The log file for the latest crash is below. If you'd like a project
>> file too, let me know, but it happens, e.g., with the gold
>> cyanobacteria project file, and with every data set I've tried.
> Hi Scott,
> I do not see this behavior on any of my computers (which include
> native WinXp and Win7 machines and linux) and I am having trouble
> guessing from the log file you attached a possible cause of the
> problem.
> Possibility #1: you are using a configuration that I cannot test.  I
> have never used Parallels and none of my computers are running Windows
> 8.  I'd be surprised if either is the cause of the problem, though.
> It seems surprising that Athena would get that deeply into its
> operations before running into a platform-related problem.  That said,
> I'd be interested to know if you see this on a native Win7 or WinXP
> machine.
> Possibility #2: you have figured out some combination of mouse clicks
> and button presses that I have never tested.  The problem you are
> seeing is that the group considered current (i.e. the one that should
> be the target of the reconstruction) has become unset.  Typically,
> when you click on an item in the group list, Athena will assign that
> as the current data set.  It will then run a simple test to see if it
> was among the data groups included in the PCA decomposition.  If so,
> the "reconstruct" button is enabled.  If not, the TT button is
> enabled.
> I cannot find a compbination of events that leaves me in a state that
> unsets this, resulting in your stack trace.  So without further
> instruction, I don't know how to go about solving the problem.
> B

More information about the Ifeffit mailing list