[Ifeffit] Athena doesn't start - Larch server not running

Bruce Ravel bravel at bnl.gov
Thu Feb 14 17:31:26 CST 2013

Hi Ivan,

OK!  I just pushed a fix to github that turns off the use of larch in
Athena.  If you do "git pull" and rebuild demeter, I think you'll be

I don't think there are similar problems lurking in Demeter's head at
github at the moment, but surely you'll let me know if anything goes

Again, sorry for the confusion.  I really need to be more careful in
the future.


PS: For those following Larch developments, I have begun working on
integrating the use opf larch into Demeter.  I should have Athena
working with larch within a month or two.  At the moment, about 25% of
Athena can use larch correctly.  It's pretty exciting!  I see about a
30 or 40 % speed improvement with Larch compared to Ifeffit, which is
more or less consistent with what Matt reported here several weeks

On Thursday, February 14, 2013 10:44:47 PM Ravel, Bruce wrote:
> I'm really sorry.  I left Demeter in a broken state on github.  I am
> currently at work getting Demeter to use Larch, but it is most certainly
> not ready for prime-time.
> I will disable the use of larch in Demeter and push that to github.  I am
> currently at the beamline, so it will be an hour or two before I get to
> that.  I'll post to the list when I do so.
> At that time, do a "git pull" then rebuild and re-install Demeter.
> Again, sorry for the confusion.  100% my fault for being sloppy.
> B
> ________________________________
> From: ifeffit-bounces at millenia.cars.aps.anl.gov
> [ifeffit-bounces at millenia.cars.aps.anl.gov] on behalf of Ivan Stijepovic
> [ivan.stijepovic at gmail.com] Sent: Thursday, February 14, 2013 5:33 PM
> To: ifeffit at millenia.cars.aps.anl.gov
> Subject: [Ifeffit] Athena doesn't start - Larch server not running
> Dear Bruce and other people in the list,
> I have just installed Demeter from the git on Ubuntu 12.04 using
> instructions given by Dave Hughes
> (https://gist.github.com/waveform80/3959252). Everything went fine during
> installation but then I tried to start Athena using dathena command from
> the terminal and I got this message:
> Demeter says: Uh oh! You have requested using Larch, but there is no Larch
> server running!
> Then I installed Larch (with some problems during installation, but that is
> different story) and again tried starting Athena with the same result. When
> I tried starting Larch in a server mode with larch -r command it didn't
> offer a possibility to start Athena in the same terminal window. Then I
> opened a new tab in the terminal and just typed dathena and the GUI
> appeared. Now, I have two questions: 1. Do I have to start Larch server
> every time like this before using Athena or is there some other solution
> for this? 2. I tried Artemis without Larch server running and didn't get
> the error message. Is Artemis independent from Larch or are there some
> problems that might occur later?
> --
> Best wishes,
> Dr Ivan Stijepović
> Department of Materials Engineering
> Faculty of Technology
> University of Novi Sad
> Bul. cara Lazara 1
> 21000 Novi Sad
> Serbia
> tel: +381 21 485 3750
> fax: +381 21 450 413
> e-mail: ivan.stijepovic at gmail.com<mailto:ivan.stijepovic at gmail.com>


 Bruce Ravel  ------------------------------------ bravel at bnl.gov

 National Institute of Standards and Technology
 Synchrotron Methods Group at NSLS --- Beamlines U7A, X24A, X23A2
 Building 535A
 Upton NY, 11973

 Homepage:    http://xafs.org/BruceRavel
 Software:    https://github.com/bruceravel

More information about the Ifeffit mailing list