[Ifeffit] Sudden Difficulty with Importing Data into Athena

Bruce Ravel bravel at bnl.gov
Thu Feb 2 11:53:20 CST 2012


Since the last time things were worting has anything changed on your
computer?  Did you (or you IT administrator) run a particularly
aggressive virus scan?  Did you install a new version of perl?  Or
something that brings along a version of perl (git, for example)?

How about the tried and true method of unistalling and reinstalling?

Your symptons (no plot in the column selection dialog, edge energy
unset, FFT kmin = -2) all indicate that no data is being read from the
file into Ifeffit.  But it is not clear from your description why that
is happening.


On Thursday, February 02, 2012 12:22:34 pm Tony Kelly wrote:
> Hopefully this is not long winded, but I want to be as detailed with
> the problem as I can be.  In the past, I have never had difficulty
> importing data into Athena, given it was formatted properly.  It was
> working as recently as last night, but suddenly I have a problem
> today.
> 1.  I open Athena
> 2.  I go to File->Open Files
> 3.  I click on the data file to bring me to the window where I choose
> Energy, Numerator, Denominator for the data and any reference spectra,
> etc
> 4.  I choose the Energy, Numerator and Denominator
> This is when the first moment of "oddness" happens... I don't get a
> plot.  Normally, I would get a plot of the spectra I am about to
> import to know if I selected the correct columns with the correct sign
> (and whether a Log is needed).
> 5.  Confused, I continue anyway and import my choices.
> 6.  I then get the following error from Athena:
> The following problems were found for group "Fe.060"
>  1  : The edge energy is unset
>  2  : The kmin for the forward transfer is negative (-2)
> You should fix these values before continuing analysis of these data.
> Note 1: I was trying with some old data that I have analyzed in the
> past from Athena through Artemis and know to be okay for analysis.
> Note 2: I then tried studying some MnO spectra by importing that data
> taken during the 2011 XAFS Summer School in Chicago taken from APS.  I
> know these text files to work, as we looked at them AT the summer
> school.
> Note 3:  As a last resort, I tried downloading the Fe example from the
> Athena website (as you can see above from Fe.060), but it can't even
> read this in.
> Note 4: Athena CAN open old projects where the data was already
> imported without problems... it just seems I can't start a new project
> and import data into it successfully.  I have tried searching all
> through the internet for anyone who had the error above or my
> difficulties to no avail.  I have tried making sure the line breaks
> were correct by resaving data into new files through textwrangler and
> even going through vim in a terminal, to no avail.
> Note 5: As a last resort, I reinstalled iXAFS, but this hasn't fixed
> the problem.
> Anyone have any suggestions?  Am I suddenly forgetting a step in the
> data import process?
> Thanks,
> Tony Kelly
> Air Force Institute of Technology
> Nuclear Physics and Engineering
> _______________________________________________
> Ifeffit mailing list
> Ifeffit at millenia.cars.aps.anl.gov
> http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit


 Bruce Ravel  ------------------------------------ bravel at bnl.gov

 National Institute of Standards and Technology
 Synchrotron Methods Group at NSLS --- Beamlines U7A, X24A, X23A2
 Building 535A
 Upton NY, 11973

 My homepage:    http://xafs.org/BruceRavel
 EXAFS software: http://cars9.uchicago.edu/ifeffit/Demeter

More information about the Ifeffit mailing list