[Ifeffit] Horae problems Ubuntu [11.10 Oneiric]

denis.testemale denis.testemale at grenoble.cnrs.fr
Tue Oct 25 13:37:33 CDT 2011

 Hello Carlo (and the list).
 Now it works (Athena/Artemis/Hephaestus). I didn't do an exhaustive 
 investigation, I just checked that I could start the programs, get the X 
 window (that I could never get before, with the error message) and read 
 a project file.

 Thanks for the fix! Let me know if I can be of further help for your 
 investigation of the problem.


 Hi again Denis:

 On Mon, 24 Oct 2011, denis.testemale wrote:

> Problem:
> after upgrading to Ubuntu Oneiric 11.10, I now cannot start 
> Athena/Artemis,
> with the following error:
> /usr/bin/perl: symbol lookup error: /usr/lib/libpgplot.so.5: 
> undefined
> symbol: XOpenDisplay
> Hephaestus runs, but I tried to plot something from it (i.e. f' and 
> f''
> plots) and it crashes (with the same error).
> I uninstalled and reinstalled Horae with the sources list up to date
> (deb http://debian-xray.iit.edu sid main contrib non-free
> deb http://debian-xray.iit.edu oneiric main contrib non-free)
> but without success.

 The problem is in the new build of pgplot5 with gfortran 4.6 and,
 possibly, the latest version of debhelper.  In order to temporarily
 resolve this problem while I figure out how to fix it permanently, I 
 posted new pacakges for natty and oneiric on the debian-xray.iit.edu

 Please let me know if it still won't work.


 Carlo U. Segre -- Duchossois Leadership Professor of Physics
 Associate Dean for Graduate Admissions, Graduate College
 Illinois Institute of Technology
 Voice: 312.567.3498            Fax: 312.567.3494
 segre at iit.edu   http://phys.iit.edu/~segre   segre at debian.org

 Denis Testemale
 Institut Néel - Département MCMF
 25 avenue des Martyrs
 38042 Grenoble, France

 ph: +33 476 881 045
 email: denis.testemale at grenoble.cnrs.fr

More information about the Ifeffit mailing list