[Ifeffit] Athena crash during LCA

Jeff Terry terryj at iit.edu
Fri Jan 7 21:54:58 CST 2011

Hi Scott, 

It seems to work for norm(E) fitting with Athena 0.8.061 under OS X 10.6.


On Jan 7, 2011, at 8:07 PM, Scott Calvin wrote:

> Hi all,
> Athena has been crashing for me during one particular linear combination analysis, and I'm wondering if any of you have an explanation. A project file which demonstrates the problem is attached. I am using Athena 0.8.054 with ifeffit 1.2.10 on a MacBook Pro using OS 10.5.8.
> The behavior can be seen by trying to fit the Data group by using a linear combination of Standard 1 and Standard 2 in chi(k). It gets as far as "plotting in k-space from group 'Data'...done!' and then hangs, with the watch icon remaining indefinitely. This doesn't happen in norm(E) or deriv(E) fits, and doesn't happen when Standard 1 is not used. But Standard 1 appears to have uncorrupted chi(k) data when plotted directly. Standard 1 is from one of the XDAC lines at NSLS, as are the standards that work.
> I've tried saving Standard 1 and reading it in as a new group, but no luck. I've also looked at the data in Standard 1, and I don't see anything out of place, such as a place where the energy backs up. I've tried starting the chi(k) file with zero values, truncating the end values, and changing the background spline to end at the same point the data does. And it always hangs at the same point.
> Any ideas? I'd like to use this data for a workshop next week!
> --Scott Calvin
> Faculty at Sarah Lawrence College
> Currently on sabbatical at Stanford Synchrotron Radiation Laboratory
> <LCACrash.prj>
> _______________________________________________
> Ifeffit mailing list
> Ifeffit at millenia.cars.aps.anl.gov
> http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit

More information about the Ifeffit mailing list