[Ifeffit] Trouble running Demeter 0.9.6 under Parallels

Scott Calvin scalvin at sarahlawrence.edu
Mon Dec 26 15:48:54 CST 2011


Thanks for pointing me toward that file, Bruce; examining it and a little tinkering allowed me to resolve the problem.

While it is a somewhat unusual sequence of events which triggered it, I will detail them here in case it is a symptom of some more general issue:

Back in August, I installed Demeter in the default directory the installer defaults to, that is \\psf\Home\strawberry (that's on the OS X disk). Previously, we determined that doing so results in the Hephaestus filters and the Athena FT phase correction failing. So I had reinstalled in C:\strawberry. That worked fine for Demeter 0.4. With the installer for Demeter 0.9.6, however, it apparently still looks for a few files in the \\psf directories, even when I direct it to install on C:\, and that causes trouble.

So my solution was to uninstall from the C:\ drive, and then install to the \\psf drive. I then uninstalled from the \\psf drive--something I had never bothered to do previously. I then reinstalled to the C:\ drive and--voila!--it works fine.

I have attached the log file from when the program first crashed.

--Scott Calvin
Sarah Lawrence College

On Dec 26, 2011, at 12:51 PM, Bruce Ravel wrote:

> On Monday, December 26, 2011, 01:09:20 pm, Scott Calvin wrote:
> 
>> Hi all,
>> 
>> I'm having trouble running Demeter 0.9.6 under Parallels, and I'm wondering
>> if anyone has had a similar problem, and/or a suggested solution.
>> 
>> I have a MacBook Pro running Snow Leopard (10.6.8) and Windows XP SP2 under
>> Parallels 6. Demeter 0.4 was running fine. I attempted to install Demeter
>> 0.9.6, and it appeared to install normally, but when I launched Athena I
>> noticed I was still in 0.4. Some poking around individual files seemed to
>> confirm they had not been replaced. I then tried uninstalling Demeter--it
>> said it was uninstalling 0.9.6, but got rid of 0.4, as I intended. I then
>> installed 0.9.6, which again seemed to work. Upon trying to launch any of
>> the components of Demeter (Athena, Artemis, Hephaestus, Atoms) the splash
>> box appears, sticks around a few seconds, and then disappears, along with
>> the black DOS window. No notice of a crash appears; the program just fails
>> to launch.
>> 
>> Any ideas?
> 
> Well, an actionable bug report would certainly help.
> 
> If you are running this on Windows, please send me the file
> %APPDATA%\demeter\dathena.log, which contains the error messages
> associated with the problem you observed.  
> 
> On Windows XP, %APPDATA% = C:\Documents and Settings\<user name>\Application 
> Data\
> 
> On Windows 7, %APPDATA = C:\Users\<user name>\AppData\Roaming
> 
> If you are running this on linux, start athena from the command line
> by typing "dathena", then cut and paste the error messages from the
> crash into your email.
> 
> When the new software crashes, a useful bug report contains those
> error messages.  If you do not send me those error messages, I will not
> be able to help you.
> 
> 
> B
> 


-------------- next part --------------
A non-text attachment was scrubbed...
Name: dathena.log
Type: application/octet-stream
Size: 546 bytes
Desc: dathena.log
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20111226/54d56a3c/attachment.obj>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: ATT00001..txt
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20111226/54d56a3c/attachment.txt>


More information about the Ifeffit mailing list