[Ifeffit] IXAFS3.0.2 and python scripting

Brugger, Joel (SAM) Joel.Brugger at samuseum.sa.gov.au
Thu Sep 9 09:41:42 CDT 2010

Dear Matt,

Works great on 10.6 for us too. Thanks a million times, and fingers crossed for finding the error in 10.5 !

We tried the python scripting, but apparently a /Users/Newville still lurks in there. 

Running the aps-12p9mLiCl.py  script

1. #!/usr/bin/python
3. import math
4. import Ifeffit
5. iff = Ifeffit.Ifeffit()

gives the following error:

bash-3.2$ python aps-12p9mLiCl.py 
 failed to load ifeffit library  libifeffit.dylib
/Users/Newville/Codes/ifeffit/local/share/ifeffit:/opt/local/bin:/opt/local/sbin:/opt/pgi/osx86/10.4/bin:/Users/joelb/Public/XDS/XDS-OSX_Intel:/Applications/iXAFS.app/Contents/Resources/local/bin:/opt/local/bin:/opt/local/sbin:/sw/bin:/sw/sbin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/X11R6/bin:/usr/local/lib:/Users/joelb/Desktop/FitYK/:/usr/local/lib/:/sw/lib/:/sw/include/readline/:/unix/Molecular Dynamics/moldy-2.16e:/Users/joelb/Public/XDS/XDS-OSX_Intel:/Users/joelb/Desktop/fdmnes:/usr/local/lib:/Users/joelb/Desktop/FitYK/:/usr/local/lib/:/sw/lib/:/sw/include/readline/:/unix/Molecular Dynamics/moldy-2.16e:/Users/joelb/Public/XDS/XDS-OSX_Intel:/Users/joelb/Desktop/fdmnes:/Applications/iXAFS.app/Contents/Resources/local/bin
Traceback (most recent call last):
  File "aps-12p9mLiCl.py", line 5, in <module>
    iff = Ifeffit.Ifeffit()
  File "/Library/Python/2.6/site-packages/Ifeffit/Ifeffit.py", line 79, in __init__
    raise ImportError('Cannot load ifeffit library')
ImportError: Cannot load ifeffit library

I tried to add /Applications/iXAFS.app/Contents/Resources/local/lib to PATH (there's a libifeffit.dylib there), but that did not help.

Also notice that my PATH variables have been duplicated. This happens because I still have '. /Applications/iXAFS.app/Contents/Resources/local/bin/iff_init.sh' in my '.profile'. Do I need to keep this? If so, it would be nice to fix iff_init.sh too :-)


Joel + Barb


Today's Topics:

   1. Re: iXAFS3.0.2 (Matt Newville)


Message: 1
Date: Wed, 8 Sep 2010 11:36:06 -0500
From: Matt Newville <newville at cars.uchicago.edu>
To: XAFS Analysis using Ifeffit <ifeffit at millenia.cars.aps.anl.gov>
Subject: Re: [Ifeffit] iXAFS3.0.2
        <AANLkTinmG5RGjBwj5eX5yui2JQo_nEP+1JJuMMdWPndh at mail.gmail.com>
Content-Type: text/plain; charset=windows-1252

Hi Brandon,

Thanks for the report.   I've seen the same errors on the only system
I have access to running 10.5.something: All the executable programs
(perl, ifeffit) report the same dyld error.    I thought these
messages were perhaps because I had built a "universal binary" that
included x86_64 and i386, so I rebuilt for i386 but not x86_64, hoping
that would solve the problem.  But it didn't.

I've looked into a little bit more (if anyone knows more, please let
me know!!), and believe the issue may be solved by adding compiler
flags of    -mmacosx-version-min=10.5 -isysroot
I have not tried this yet, but will try to get this rebuilt in the
next day or two.

Sorry for the trouble.

FWIW, I still get results I don't understand on PPC, where ifeffit and
artemis run but hephaestus are artemis do not.... isn't that amazing?


More information about the Ifeffit mailing list