[Ifeffit] updating Athena in Windows 7 (Matt Newville)

Laurent Menard menard at email.unc.edu
Tue Aug 10 18:47:03 CDT 2010


I don't know what your update failure exactly was but if the status bar
showed that the zip file was downloaded and they you got stuck on the
extraction part of the update it is likely a write permission problem.  Your
issue with saving the .ini file would fit with that.

Even if you have administrator permissions you may need to change your
security settings.  Try this:

Right click on the IFEFFIT folder in Program Files and select Properties.
Select the Security tab and then click the Edit button.  For all of the
group or user names listed make sure Allow is marked for all permissions
(Checking Full Control should select all of the permissions in the list
below it).  Hit the Apply button and then the OK button.  Then try opening
Athena again and see if it successfully runs through the update process.  If
you haven't changed the freq. that Athena looks for updates then you can
just change the date in Windows to the next day, run Athena, and then change
it back to the correct date.

I'm sure there's a way to do this globally but I don't know what it is.
I've done this with a few programs where I had write permission issues in
Windows 7 (e.g. ImageJ) and it usually works.


-----Original Message-----
From: ifeffit-bounces at millenia.cars.aps.anl.gov
[mailto:ifeffit-bounces at millenia.cars.aps.anl.gov] On Behalf Of Monson, Todd
Sent: Tuesday, August 10, 2010 6:12 PM
To: ifeffit at millenia.cars.aps.anl.gov
Subject: Re: [Ifeffit] updating Athena in Windows 7 (Matt Newville)

I tried resetting the timestamp to 0 under:  Ifeffit\config\updater.ini.
However, I could not save the changed updater.ini file.  I verified that I
have administrator privileges on my computer.  Could something else be
preventing me from updating the updater.ini file and in turn updating

Date: Wed, 28 Jul 2010 07:37:52 -0500
From: Matt Newville <newville at cars.uchicago.edu>
To: XAFS Analysis using Ifeffit <ifeffit at millenia.cars.aps.anl.gov>
Subject: Re: [Ifeffit] updating Athena in Windows 7
	<AANLkTinxBX3aCXUGdN5XZCajMuK5gWCyftb9N-6YvpVz at mail.gmail.com>
Content-Type: text/plain; charset=ISO-8859-1

Hi Todd,

On Mon, Jul 26, 2010 at 3:39 PM, Monson, Todd <tmonson at sandia.gov> wrote:
> On Saturday, while starting up Athena, I was informed that there was 
> an update to Athena available.? I tried installing the update but 
> failed.? I am afraid this is due to some user permission issue in 
> windows 7.? How can I try to reinstall the update and ensure that it

You can change the file current.dat in C:\Program Files\Ifeffit\config.  It
probably reads


right now, and you could change that to 012 or even lower.  That will cause
an update the next time ifeffit looks for updates, which only happens when
one of the programs starts and if the time in Ifeffit\config\updater.ini is
past.  To force a check for updates the next time ifeffit runs, change
updater.ini to read

timestamp = 0

In general, I believe this should work for Windows 7 (I have access to two
Windows 7 64-bit machines, and all seems to be working on them, though I
admit to not stressing them too much).  So, as you say, I would also guess
that the trouble you had was "only" permission issues.  But, please let us
know how it goes,

Sorry for the trouble,



Ifeffit mailing list
Ifeffit at millenia.cars.aps.anl.gov

End of Ifeffit Digest, Vol 89, Issue 19

Ifeffit mailing list
Ifeffit at millenia.cars.aps.anl.gov

More information about the Ifeffit mailing list