[Ifeffit] updating Athena in Windows 7 (Matt Newville)

Monson, Todd tmonson at sandia.gov
Tue Aug 10 17:11:56 CDT 2010


Matt,
I tried resetting the timestamp to 0 under:  Ifeffit\config\updater.ini.  However, I could not save the changed updater.ini file.  I verified that I have administrator privileges on my computer.  Could something else be preventing me from updating the updater.ini file and in turn updating Athena?
Todd

Date: Wed, 28 Jul 2010 07:37:52 -0500
From: Matt Newville <newville at cars.uchicago.edu>
To: XAFS Analysis using Ifeffit <ifeffit at millenia.cars.aps.anl.gov>
Subject: Re: [Ifeffit] updating Athena in Windows 7
Message-ID:
	<AANLkTinxBX3aCXUGdN5XZCajMuK5gWCyftb9N-6YvpVz at mail.gmail.com>
Content-Type: text/plain; charset=ISO-8859-1

Hi Todd,

On Mon, Jul 26, 2010 at 3:39 PM, Monson, Todd <tmonson at sandia.gov> wrote:
> On Saturday, while starting up Athena, I was informed that there was 
> an update to Athena available.? I tried installing the update but 
> failed.? I am afraid this is due to some user permission issue in 
> windows 7.? How can I try to reinstall the update and ensure that it works?

You can change the file current.dat in C:\Program Files\Ifeffit\config.  It probably reads

013

right now, and you could change that to 012 or even lower.  That will cause an update the next time ifeffit looks for updates, which only happens when one of the programs starts and if the time in Ifeffit\config\updater.ini is past.  To force a check for updates the next time ifeffit runs, change updater.ini to read

timestamp = 0

In general, I believe this should work for Windows 7 (I have access to two Windows 7 64-bit machines, and all seems to be working on them, though I admit to not stressing them too much).  So, as you say, I would also guess that the trouble you had was "only" permission issues.  But, please let us know how it goes,

Sorry for the trouble,

--Matt


------------------------------

_______________________________________________
Ifeffit mailing list
Ifeffit at millenia.cars.aps.anl.gov
http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit


End of Ifeffit Digest, Vol 89, Issue 19
***************************************





More information about the Ifeffit mailing list