[Ifeffit] Ifeffit/iXAFS won't launch in OS 10.6 (Snow Leopard)

Joel Kelly joel.kelly at ualberta.ca
Tue Sep 8 16:11:59 CDT 2009


I recently upgraded to OS 10.6 (snow leopard) on my intel Mac. It
comes with version 2.3.4 of X11.

Now, I can't seem to run any of the Horae GUI applications! I've tried
launching Athena from iXAFS or from the stand alone IFEFFIT suite.

When I run iXAFS, the normal launch window with Athena, Artemis,
Hephaestus and the iXAFS shell appears. Clicking on the Athena,
Artemis, and icons Hephaestus causes X11 to launch with an xterm
window, but Aquaterm does not load. However, the iXAFS shell seems to
load, though I'm not experienced enough with the shell to know if it's
fine or not.

Upon launching the Athena standalone program from IFEFFIT (downloaded
here: http://cars9.uchicago.edu/~ifeffit/src/Ifeffit-1.2.10-Mac10.4_Intel_horae066.dmg),
clicking on "X11 graphics" launches xterm but not Aquaterm, and
clicking on "Aquaterm" closes the program.

Not sure if this is a Snow Leopard related problem or not- there has
been a new version of X11 released (2.4) that is unsupported in OS
10.6, and unfortunately it doesn't seem to allow me to install a
previous 2.3.2 version. Looks like I'll have to downgrade back to
Leopard, these cat names are getting confusing. Has anyone experienced
anything similar, or have any insight on how to fix the problem?

Best regards,
Joel Kelly
University of Alberta

More information about the Ifeffit mailing list