[Ifeffit] chi(k) Athena bug?

Olivier olivier.jacquat at env.ethz.ch
Thu Sep 4 08:13:17 CDT 2008


Hi Bruce,

Yes, you're right.
Here one of the files (sorry for the omission). Note that with other files
of chi(k) (either measured or simulated), the same "problem" appears.

Best regards,
Oli


++++++++++++++++++++++++++++++++++++:-)
Olivier Jacquat
Soil Chemistry group
Institut of Biogeochemistry and Pollutant Dynamics
ETH Zürich
Universitätstrasse 16, CHN F71
8092 Zürich-Switzerland
Tel: +41 44 633 60 28
Fax: +41 44 633 11 18
Email: olivier.jacquat at env.ethz.ch
Url:http://www.ibp.ethz.ch/people/ojacquat/index
-----Original Message-----
From: ifeffit-bounces at millenia.cars.aps.anl.gov
[mailto:ifeffit-bounces at millenia.cars.aps.anl.gov] On Behalf Of Bruce Ravel
Sent: jeudi, 4. septembre 2008 14:50
To: XAFS Analysis using Ifeffit
Subject: Re: [Ifeffit] chi(k) Athena bug?



Olivier,

This is a bit confusing.  I want to be sure I understand the most
salient point:

 1. You have a file of chi(k) that does not start at 0

 2. The current version of Athena fails to read this correctly.

 3. The current version of Artemis is able to read this correctly.

Is that right?  Can I see the data file?  (Once again: problems can't
be fixed if I cannot reproduce them on my own computer.)

B


On Wednesday 03 September 2008 19:33:31 Olivier wrote:
> Dear all,
>
>
>
> I recently performed FEFF calculations to model chi(k) spectra. The
> generated chi.dat files had chi(k) data starting at 1.4k.
>
>
>
> When importing the data (chi.dat) in Athena (version 0.8.056) using
IFEFFIT
> 1.2.11 (XP OS), Athena was not able to interpolate the data from 0 to xk
(x
> being the starting k value of the file, in my case 1.4). Thus Athena could
> only read the data in but no changes were visible in the plot window when
> changing parameters (e.g. k-weight, looking at the FT). The plot window
> just ?froze?. Yet the echo and Ifeffit buffer indicated that the changes
> had been taken into account. I tried to uncheck the buffering and storing
> options in the plot window without success.
>
>
>
> In contrast, with the newest version of Artemis (i.e. 0.8.012, or previous
> versions of Athena, e.g. 0.8.054), I was able to read and play with any
chi
> data.
>
>
>
> To look at the data in Athena 0.8.056 I simply added a 0-1.4k interval
with
> a 0.05k grid and set chi(k) to 0 in this interval.
>
>
>
> Do you also experience this tiny Athena 0.8.056 (XP OS) bug?
>
> Or is there a workaround?
>
>
>
> Best regards,
>
>
>
> Oli
>
>
>
> ++++++++++++++++++++++++++++++++++++:-)
> Olivier Jacquat
> Soil Chemistry group
> Institut of Biogeochemistry and Pollutant Dynamics
> ETH Zürich
> Universitätstrasse 16, CHN F71
> 8092 Zürich-Switzerland
> Tel: +41 44 633 60 28
> Fax: +41 44 633 11 18
> Email: olivier.jacquat at env.ethz.ch



-- 
 Bruce Ravel  ------------------------------------ bravel at bnl.gov

 National Institute of Standards and Technology
 Synchrotron Methods Group at NSLS --- Beamlines U7A, X24A, X23A2
 Building 535A
 Upton NY, 11973

 My homepage:    http://xafs.org/BruceRavel
 EXAFS software: http://cars9.uchicago.edu/~ravel/software/exafs/


_______________________________________________
Ifeffit mailing list
Ifeffit at millenia.cars.aps.anl.gov
http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Athena_chi.dat
Type: application/octet-stream
Size: 38007 bytes
Desc: not available
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20080904/e2cde556/attachment.obj>


More information about the Ifeffit mailing list