[Ifeffit] [PGPLOT build problem] Upgrading to ifeffit-1.2.11b on Ubuntu from source

Mauro Rovezzi rovezzi at esrf.fr
Wed Nov 12 03:10:03 CST 2008

Dear all,

I decided to upgrade ifeffit-1.2.11 on my Ubuntu 8.10 (Intrepid Ibex) 
desktop machine. Well, up to now I have always worked with PGPLOT & 
Ifeffit binaries from Carlo that are just working fine but seen that 
they are still not ready for the new version I decided to build them by 

First of all let me say that Ifeffit builds fine if I use the "pgplot5" 
binary package, BUT, as stated by Matt in the README.PGPLOT, Ifeffit 
will compile without plotting support in this case.

So the only way is to build also PGPLOT from source. Unfortunately the 
experience has failed both with the "PGPLOT_install" script and 
following steps in the "install-unix.txt".

I have tried many possibilities but the make process interrupts on the 
drivers compilations. Seen that following "install-unix.txt" gives the 
same error (but on another driver!) of "PGPLOT_install", let's focus on 
this last procedure to try debugging the situation:

$sudo ./PGPLOT_install
[all fine until the PGPLOT make]
[long list of errors + warnings like:]
error: ‘XWdev’ has no member named ‘gc’
make: *** [xwdriv_iff.o] Error 1
[then the final error due to the bad compilation]
collect2: ld returned 1 exit status
make: *** [pgdemo1] Error 1

OK, I have described more or less the situation but I would not flood 
the list with technical mails, so if someone would help me with this 
issue we can continue in private and then send just the solution to the 

Anyway, the problem is not "urgent" seen that I can work with the 1.2.10 
  binary installation.

Have a nice day!

Mauro Rovezzi <rovezzi at esrf.fr>
PhD student - GILDA BM08 c/o ESRF (Grenoble, FR)

More information about the Ifeffit mailing list