[Ifeffit] compilation problem under MacOSX 10.4 - again

Matt Newville newville at cars.uchicago.edu
Thu Sep 1 22:20:03 CDT 2005


Hi Hugh,

> I'm new to the list and ifeffit. 

Welcome!

> I'm new to the list and ifeffit. I've tried to get ifeffit 1.2.7
> installed (for the first time) under tiger (on a system upgraded from
> panther) according to the instructions posted in the FAQ and the
> following modification on the list;
>
> I have Xcode installed, g77 via fink, and ran the ifeffit binary
> installer. Perl/Tk seemingly builds and installs ok but when I try to
> build horae 0.5.3 I get the following error;

I think the binary installer won't work by itself for 10.4, and you'll
also need to install
the Ifeffit library from source.   It wasn't clear whether you had
done this or not, but
the message from horae's "perl Makefile.PL; make" that 'ifeffit -i'
failed definitely means that the basic ifeffit is not working.

I think you should try these steps (in a Terminal):
1.  Set up the Shell.  At the command prompt type  
   ~> . /Applications/Ifeffit/bin/iff_init.sh     # note the '.' !! 
    if you're using bash or
   ~> source /Applications/Ifeffit/bin/iff_init.csh
    if you're using tcsh.  If you're not sure which shell you're using
try both, and then
    you'll know.
2. download the ifeffit source kit (ifeffit-1.2.7.tar.gz) and do
   ~> tar xvzf  ifeffit-1.2.7.tar.gz
   ~> cd ifeffit-1.2.7
   ~> ./configure --prefix=/Applications/Ifeffit
   ~> make 
   ~> sudo make install

At that point you should be able to type 
     ~> ifeffit -i

and have it say 
  /Applications/Ifeffit/share/ifeffit

at that point, I think you'll be ready to install horae.

Good luck! 

--Matt




More information about the Ifeffit mailing list