[Ifeffit] Re: athena for OSX.4

Paul Fons paul-fons at aist.go.jp
Mon May 9 19:18:39 CDT 2005


Please excuse me for forwarding a copy to the list in case there are  
others out there that have run into the same problem.
For all those who want to be Tigers (Mac OS 10.4), here is a brief  
summary of the installation procedure.  I should add that there is  
not an installer that will do everything at once, but the procedure  
is really pretty easy.

I have not tried installing horae on a brand new system, I have only  
tried (and succeeded) in making a previously functional horae-051  
under Mac OS 10.3 work properly under Mac OS (Tiger) 10.4.

The errors you see are generated because there is a new version of  
perl installed (5.8.6) which doesn't know about Perl/Tk, the graphics  
system that Bruce uses for all of his packages.  The solution is  
simple, you must download and install Perl/Tk and then reinstall  
horae.  After that everything just works again. The build procedure  
is nearly automatic, but you need to have installed the developer  
tools (which are included on the Tiger installation DVD).

First you need to download Tk from CPAN (the server where free Perl  
software is hosted). Here is the procedure.

0.  I assume you had an installed and functional horae running under  
10.3 and did an upgrade to 10.4

1. Download the source for Tk by
     a. make a new (temporary) scratch directory

                 mkdir temp;
                 cd temp

     b. download Tk going in your browser of choice go to the web  
page:  http://search.cpan.org/~ni-s/Tk-804.027/ and hitting the  
download button on that page
                 (the file will be named Tk-804-2.027.tar.gz)
    c. uncompress the file in your scratch directory

               tar zxf   /the-path-to-your-download-directory/ 
Tk-804-2.027.tar.gz

    d.  change to the Tk directory, compile, and install the new Tk

             cd Tk-804.027
             perl Makefile.PL
             make
             sudo make install

e.   now you must download and install the latest version of horae  
via Bruce's web page

           go to the site http://leonardo.phys.washington.edu/~ravel/ 
software/downloads.html#unix and use the download link for  
horae-051.tar.gz

f.   decompress and install the new horae source

             cd ../temp   (move up from the Tk directory to the top  
level of your new temporary directory)
             tar zxf /the-path-to-your-download-directory/ 
horae-051.tar.gz
             cd horae-051
             perl Makefile.PL
             make
             sudo make install



That's it. You are done.  I just popped up a X11 window (you did  
remember to install the X11 program which is an optional install on  
the Tiger DVD accessible using the "Customize" button in the  
installer, right?) and typed

                 artemis &


and poof, artemis appeared.  Note that if you did a clean install you  
should still be able to get everything working by downloading Matt's  
installer and installing the 10.3 copy (it won't work out of the box)  
and then following the above procedure.  I have not verified this,  
however, so caveat empor as the Romans said...

Hope this helps.

                                 Paul


On May 10, 2005, at 3:08 AM, denauwer at tele2.fr wrote:


> Dear Paul,
>
> We have contacted Bruce because we want to use Athena on Mac OSX.4  
> and it is not working. We have tried from the terminal and we got  
> the following message:
>
> "Can't load '/Library/Perl/5.8.1/darwin-thread-multi-2level/auto/Tk/ 
> Event/Event.b
> undle' for module Tk::Event: dlopen(/Library/Perl/5.8.1/darwin- 
> thread-multi-2lev
> el/auto/Tk/Event/Event.bundle, 1): Library not loaded: /System/ 
> Library/Perl/5.8.
> 1/darwin-thread-multi-2level/CORE/libperl.dylib
>   Referenced from: /Library/Perl/5.8.1/darwin-thread-multi-2level/ 
> auto/Tk/Event/
> Event.bundle
>   Reason: image not found at /System/Library/Perl/5.8.6/darwin- 
> thread-multi-2lev
> el/XSLoader.pm line 68.
>  at /Library/Perl/5.8.1/darwin-thread-multi-2level/Tk/Event.pm line 10
> Compilation failed in require at /Library/Perl/5.8.1/darwin-thread- 
> multi-2level/
> Tk.pm line 13.
> BEGIN failed--compilation aborted at /Library/Perl/5.8.1/darwin- 
> thread-multi-2le
> vel/Tk.pm line 13.
> Compilation failed in require at /Applications/Ifeffit/bin/athena  
> line 53.
> BEGIN failed--compilation aborted at /Applications/Ifeffit/bin/ 
> athena line 53.
> Undefined subroutine &Tk::Event::CleanupGlue called at /Library/ 
> Perl/5.8.1/darwi
> n-thread-multi-2level/Tk/Event.pm line 3.
> END failed--call queue aborted at /Applications/Ifeffit/bin/athena  
> line 53."
>
> Could you if you have time, please, explain what we have to do to  
> fix this problem?
>
> Thank you for your help,
> Christophe Den Auwer
>
>





More information about the Ifeffit mailing list