[Ifeffit] Bugs in new versions of Athena and Artemis

Schmithals schmithals at hmi.de
Thu Mar 11 13:48:15 CST 2004


thanks for the comprehensive response to my questions.

> You can edit the titles on the data page to put your own information
> in the header written to the data chi(x) files.  But I see your point
> and will include that in the next release.

Concerning Athena I see how to work around the problems. Putting 
parameter-information in the project title is indeed a help. But usually 
the parameters will change often so an automated writing to the exported 
files would be better. I would therefore appreciate this function in a 
future release.

I will now concentrate on Artemis. I did again a new full installation 
of Ifeffit and set up the example files again, carefully looking at the 
error messages.
(BTW: Initially the FEFF-executable is set to feff6, it is necessary to 
switch to feff6l by hand).

> 1.  Did you do anything to the folders or files under
>      C:\Program Files\Ifeffit\horae\stash\artemis.project.0\ 
>    while Artemis was still running?

I did never edit any file in the \horae\ .. folders but before deleting 
the old installation I had a look there and found around 20 folders 
called "artemis.project.0", "artemis.project.1" etc. After the new 
installation the "artemis.project.0" was removed each time not 
cluttering up the folder. Could there be a relation to the errors?

> The basic flowchart for an Artemis 0.7 project is this: (1) import
> data, (2) import or create atoms data, (3) run atoms, (4) check the
> feff.inp data and run feff, (5) set up your fitting model, (6) hit the
> big green button.

I set up the project file in the order you described: and indeed 
everything works normal !

I therefore tried to reverse the order: first load in a 
feff-calculation, play with it and afterward load a data-file. The 
project file went corrupt again (error messages in ARTEMIS.TRAP). I 
tried it a few times in the "wrong order", some times it went OK. After 
a while I figured out what the problem might be:
When I load the data file (for the first time) via the dialog Data | 
Change Data File problems will occur (which I usually did despite the 
fact the the dialog was built to CHANGE an existing data file - I was 
just confused about the variety of ways to load in a data file). When I 
first load in the data file via File | Open data file or project it will 
be OK.
Does that make sense? I am sorry but the errors are not always 
reproducible and I did my best to figure out a possible scheme. I 
included a corrupted and a good file but they seemed pretty equal. When 
I load in the corrupted file a second time everything will be okay, 
probably only the copy in the stash-folder gets corrupt?

I summarize: when I follow the correct order I could not find any errors 
so far. All the different error messages I had might be related to a 
wrong loading procedure.

> (1)  Completely delete the feff calculation from the project using the
>      discard option in the Feff menu and then start over again

Do you think it is risky to delete the FEFF-calculation in the Zip-file 


-------------- next part --------------
A non-text attachment was scrubbed...
Name: Artemis.zip
Type: application/zip
Size: 186049 bytes
Desc: not available
URL: <http://millenia.cars.aps.anl.gov/pipermail/ifeffit/attachments/20040311/def5703c/attachment.zip>

More information about the Ifeffit mailing list