[Ifeffit] Problems running athena/tkatoms

Norbert Weiher norbertweiher at yahoo.de
Thu Mar 28 03:08:08 CST 2002

Hi Matt,
you're absolutely right - it seems to be a fortran problem. I tested ifeffit 
as well as gifeffit. Both work well. I tried to re-install ifeffit, the 
wrappers and athena but it didn't help. Copying the lib mentioned in your 
"Fortran Notes" to /usr/lib was also not successful. Building the wrapper is 
always successful but 'make test' aborts with the following message:

bash-2.05# make test
make[1]: Entering directory 
make[1]: Leaving directory 
PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib 
-I/usr/lib/perl5/5.6.0/i586-linux -I/usr/lib/perl5/5.6.0 test.pl
Can't load 'blib/arch/auto/Ifeffit/Ifeffit.so' for module Ifeffit: 
/usr/lib/libf2c.so.0: undefined symbol: MAIN__ at 
/usr/lib/perl5/5.6.0/i586-linux/DynaLoader.pm line 200.
 at test.pl line 14
Compilation failed in require at test.pl line 14.
BEGIN failed--compilation aborted at test.pl line 14.
make: *** [test_dynamic] Error 255

I tried to find the libf2c.so.0 lib - it's in /usr/lib. I will now try a 
re-install of gcc and g77 and keep you informed on the progress of this ;)


On Wednesday 27 March 2002 20:44, Matt Newville wrote:
> Hi Norbert,

> It may help to re-install ifeffit, or at least the perl module:
>    perl Makefile.PL ; make install
> in  ifeffit_1.0b/wrappers/perl/
> Otherwise, do ifeffit and gifeffit run?  That is, can we
> isolate this as perl+ifeffit problem or an ifeffit problem?
> If ifeffit works, does
>    perl -e 'use Ifeffit;'
> have the same problem as athena?  If this is where the problem
> is (I'd guess it is: ifeffit runs, the above perl line fails),
> then does the Makefile.PL look reasonable, pointing to libs for
> PGPLOT, X, g2c, etc that exist, etc?
> --Matt

Dipl. Chem. Norbert Weiher (norbertweiher at yahoo.de)
Institute for Chemistry - Takustr. 3 - 14195 Berlin
Phone/Fax: +49 30 838 53750 / 54792

More information about the Ifeffit mailing list